If Word Not Installed Preview is a Deception

I spent three hours of my Saturday discovering this. If you don’t have Microsoft Word installed on your Mac, preview after you compile, is flawed, but the file is not. You just can’t see it. Let me explain to avoid other users wasting so much time. (Scrivener should have a big red alert about this when compiling on a Mac).

Here is my setup. I write on a PC using Scrivener (multi screen swordfish setup). Compile does not work correctly in Windows. Standard MS format always indents paragraphs in a new text document where Mac compile does not. So I finish the novel on my PC, save a version for MAC. Go to my Mac and covert it, then compile for Word. The preview is corrupted every time because MAC does not have Word installed… but when I open the file on my PC (three hours of pulling my hair out on the MAC) the word.doc is correct. Then I can save the word file as a pdf and have two correctly formatted files.

In summary, this fiasco revealed several things. One, the variations between the Mac and the PC has always been a pain in the ass. I gave up paying attention to Windows 3.0 release nonsense. Next, is the difficulty compiling correctly in Windows. Third, the issue of preview (which makes sense I guess since my Mac can’t render a word doc correctly). This should have been an alert in the Mac software when you try to compile for a format without the related software installed.

What happens if you open the compiled Word doc in Pages?

What “Preview” are you talking about? The Quick Look Preview in Finder is generated by Mac OS, and is outside of Scrivener’s control.

No component of Mac Scrivener assumes that Word is installed, nor does Mac Scrivener use a Word installation if one exists.

Katherine

I am intrigued by this part of what you’ve told us. If I understand correctly this is why you are going through an annoying two-machine workaround in the first place. Maybe you have been this route already, but I think you might be able to get some help from the folks here to resolve this problem and avoid what must be a quite frustrating workflow. What Compile format are you using? Offhand it sounds like a paragraph setting in the format in the Win version is checked but in the Mac version not.

Does anyone know about this paragraph indents discrepancy or can help in Scriv-Win eliminate rscott’s unwanted paragraph indentation?

gr

It is the preview native to the Mac. It launches after compile for Word and I have preview selected in Scrivener)

So this is the “open in” menu below the file save dialog?

If you use that menu to open in any application other than Word itself, you’ll see the result of that application’s format converter. Again, that’s outside of Scrivener’s control.

To test, simply save the file without previewing, then open from Finder into your chosen application. You’ll see the same result.

Katherine

I wasn’t even aware that Preview.app tried to open .docx files. That seems like a strange overreach on Apple’s part to me, why not just open in TextEdit? The quality is about as good (read: bad). Whatever the case, if you’re looking for a better way to load .docx files on the Mac:

  • Pages is free and does all right.
  • LibreOffice is free and is okay as well—better if you need features and intend to actually work with the document extensively. Pages is more of a simple design tool, but has a higher quality level in .docx conversion I find.

If you’re willing to invest in a Mac tool, Nisus Writer Pro is a high quality word processor. Best thing about it, from the Scrivener perspective, is that both share the same native file format: RTF. So you dodge the whole nasty docx version snarl by pairing those two together, and your compile times be dramatically lower without conversion.

But thanks for making the thread. If someone else makes the mistake of using Preview to load Word files, hopefully they’ll find this. Definitely don’t recommend Apple’s native tools for loading Word files! We bloat Scrivener’s download size by a good 50 or 60mb purely to avoid using them—that should tell you something about it. :slight_smile: