Ignoring the time zone change in custom metadata = reverting to today's date

I recently spent three months in a different timezone (America), writing the first half of a novel. I use the custom metadata tag to keep track of what date/time different scenes are happening. This is fictional, and therefore doesn’t need to be linked to timezones – in fact, the last thing I want is for the dates/times to change automatically! Now I’m back in the UK, all the metadata time tags are five hours out, because I guess they were adjusted for the UK timezone. I found the ‘Ignore time zone change’ tick box in the custom metadata settings, but if I click this then all of the date tags on my scenes set to today’s date (a disaster! I thought I had lost the whole timeline of my book… Luckily, unticking the box reverts the dates to their original form). At the moment I’m using a workaround, setting my mac to American eastern time so I can see the correct times on my scenes. Obviously this isn’t a longterm solution though! Would really appreciate any tips/better workarounds.


Thanks for the report! I’ve noted a few odd things about this setting beyond what you reported (I can reproduce that easily enough). We’ll take a look at it.

Great to hear! I’ve run into problems with this setting (novel set in 1880s London; writing from California et al.) and had to depend on Aeon Timeline to catch it—a luxury I’m sure many don’t have.

And I’m pleased to report it will be fixed in the next update. We found a few other oddities and got them cleaned up as well.

You may have already found this oddity, but in case you haven’t:

I have a metadata date field pulled in from Aeon – which automatically sets the field with the ignore toggle on. If I have the field in the Outliner as a column fully expanded, it shows the right date, as shown here:


However, if I contract the field, if the time is after what I’m guessing is a certain time UTC*, it bumps the date to the next day, as shown here:


*(I’m in Australia. At the moment, this day jump only happens with times >= 2pm which is 3am UTC this time of year),

Is this one of the things you’d already found?

Could you please check the Project Settings to see if this date custom metadata field is set to “Ignore time zone changes”? I’ve just spotted an issue whereby the contracted formats of the dates aren’t updated to use the same time zone as the preferred date format if this setting is ticked, which may be the issue here.

Thanks and all the best,

Yup. That’s the way it comes in from Aeon (with good reason, obviously). Here’s proof (the custom format is my own tampering, but it happens with either my homebaked format or any of the standard ones when “Ignore etc.” is selected):


Once again, it only happens for dates with time components set >= 2pm, which at my location’s current daylight saving time makes it 3am UTC. We’re +10 standard, +11 DST.

Using 3.1.1, which I forgot to mention originally.

Hope that helps.

Great, thanks for the confirmation. Hopefully this is fixed for 3.1.2, then, as there was a time zone bug here. Let me know if you still see the issue in 3.1.2 when it’s out.

All the best,

Will do. Thanks for the bug splatting.

Ok, contracting columns is no longer an issue, but…

… something weird is happening with Aeon/Scrivener syncing after the update (at least for me). I’ll explain in screenshots

Here’s an event created in Aeon with date and time:

And here are the custom metadata fields that Aeon creates for syncing over to Scriv:

Here is how they appear in Scriv in the Metadata tab in the Inspector when I click on the settings cog. " Ignore time
zone changes" is ticked by default :

But the times/dates and dates in Scriv have jumped forward 11 hours (my current timezone is UTC +11):

If I create a doc in Scriv and enter dates and times like so:

… it syncs over fine into Aeon:

… but when I go back to Scriv after the sync the time jump has hit that doc as well:

… but everything remains fine in Aeon:

I’ve tried it both with and without “Ignore time zone changes”, and the shift behaviour stays the same.

Let me know if you need any further info.

After a bit of investigation (thanks to Ioa), it turns out that this is because Scrivener’s file format requires the microseconds to be included for custom meta-data dates, but Aeon is omitting these. (This isn’t Aeon’s fault, as it seems I forgot to update the file format specs with this requirement.) I have therefore added a workaround to the next update which makes the microseconds optional, so that the date will work properly without them.

Thanks and all the best,

Great! Looking forward to it.Thanks to the two of you.

Hi! I believe I am having a related problem, but I can’t quite pin it down. I have always been able to successfully sync Scrivener and Aeon files. On my current project, all of my Aeon events are showing up in Scrivener with the custom metadata field set for four hours earlier. I am writing and syncing in the same timezone (EST) as I always have. “Ignore timezone changes” is ticked. I’m baffled, and a little stuck. I’m using Scrivener 3.1.2 and Aeon 2.3.16. Any help would be somewhat urgently appreciated, as I am unable to use the sync feature at all at the moment. :frowning:

I find that the only way currently to get this working is to force Scrivener to use plain text fields instead of date-type fields. What I did:

  • In Aeon, with my project’s sync panel open, I clicked the gear icon in the upper right corner to open the project sync settings.
  • I set both Start Date and End Date to None. While the Aeon events still contained the dates, this stopped Aeon from writing them to my Scrivener metadata temporarily.
  • I closed the project’s sync panel in Aeon, and opened the project in Scrivener.
  • Then I opened Project > Project Settings… > Custom Metadata. I deleted the old Start and End fields.
  • I added new Start and End fields with slightly different names and made sure that they were plain text, single line. (See screenshot.)
  • Finally I closed the project in Scrivener, opened it again for sync in Aeon, and connected the new text metadata fields to Start Date and End Date in Aeon.

After syncing, the metadata fields in Scrivener had the correct date and time. Of course since they’re just text they won’t sort correctly in Scriv, but for me that’s a small price to pay. :smiley: Maybe after KB distributes the fix he mentioned earlier in this thread I’ll switch back to proper date/time fields, but then again, maybe not. Plain text seems to Just Work.

@silverdragon Thank you so much for replying so quickly. I very much appreciate your quick and friendly answers, in other threads as well. In fact, as I read THIS whole thread more carefully, and then looked up “what is my time zone relative to UTC?” I discovered that is exactly the offset for me -4 hours. Thanks also to @Endlessloop for including your timezone information, because that allowed me to do a little more digging. I look forward to a fix!

You’re welcome!

For anyone who’s curious, I worked out a method to make the plain text dates sortable.

  • First, in Aeon preferences, I chose Preferred Date Format : Sortable. I then synced my project.
  • Back in Scriv, I found that the only thing preventing my dates from sorting was the day of the week in the front of the date string.
  • I ran a Project Replace affecting custom metadata only, using regular expressions which I include below. Now my dates sort in Scriv, and Aeon is perfectly happy with them!

Search for:

^(Mon|Tue|Wed|Thu|Fri|Sat|Sun) (.*)$

Replace with:

$2 $1

No probs – it took a while to notice it, but it became obvious it was something to do with the problem.

Silverdragon’s workaround is great while we’re waiting for the update to hopefully get it working as it should.

Thanks for the suggestion. My problem was the time was being shifted by7 hours earlier than Aeon claimed it was going to transfer. I checked Scrivener to see if there was a setting I had to force to not adjust for timezones (unlike Aeon, which made no difference whether I changed it or not). Interestingly, making it a plain text field corrected the shift. This tells me Scrivener is DEFINITELY the culprit, but I have no idea how or why. At least I have the right time info in the metadata now.

I had the exact same problem, but mine was 7 hours… of course, I’m in Phoenix, so its UTC-7 hours here. Since Silverdragon’s suggestion to change time fields to plain text worked (and Aeon showed the proper time being transferred), then it leads me to believe that Scrivener is forcing all times to UTC. I couldn’t find any setting in the application to change that, so I’m leaving them as plain text. I only need them for reference anyway.


I’m glad to hear that my workaround is helping so many! “You’re welcome!” to all.