I'm getting double ??. Help!

I’m doing a compile of my book and for unknown reasons I’m getting double question marks, each surrounded by a border. Here’s an example:
In Scrivener: "€œThen, why are you here?"€ asked the stranger.
PDF version: “Then, why are you here?” asked the stranger.
ePub version: “??Then why are you here?”?? asked the stranger.

I can’t replicate the rectangle border around each question mark. I’m seeing that in the Kindle Previewer and double question marks without the border around each one when I use Adobe Digital Edition.

I think I might have stumbled across something.

I noticed that there’s two different quotation marks in my book. One is straight up and down " marks and the other are slanted. The straight up and down are the ones that are causing a problem.

I thought I’d do a find and replace, but for some reason Scrivener doesn’t seem to recognize some instances of the quotation marks.

I’m stumped. I can’t figure out what’s happening and this is keeping me from publishing my book. :open_mouth:

If anyone has an idea, please help.

Hoping a tech person can shed some light on this.

It sounds like you have invalid characters in there somehow, which are getting that “unknown/invalid character” symbol in ePub. I’m not sure what, though if you imported the documents something may’ve carried over from another program into Scrivener. Try to find one of the instances of the quotes that are causing the problem and then copy that and paste it into the search field of the find/replace dialogue and replace them with a regular quote to see if that fixes things–copy/paste should get the actual character in there. You could also try turning on Invisibles (Format > Options) in case you see anything extra that way, but it might not be visible even then since it’s probably just the way the character is being encoded.

Here’s what I’m up against.
What it looks like in Scrivener:

And this is what it looks like in the Kindle preview

I tried doing the find and replace, but it doesn’t seem to have changed anything.

One thing I just noticed is green dots under apostrophes when words are written like can’t. When I mouse over it a yellow window comes up in Scrivener that says “An opening quotation marks seems to be missing. Please check.”

Guys, I’m pulling my hair out. Please help.

You could try a couple of things…

Compile just a selection (one scene) to plain text, and then copy that document’s contents back into scrivener (take a snapshot first!). Then do the compile and see if that fixes anything.

Delete one of the problematic quotes by hand. Compile and see if the extra symbols/characters are still present. If there are weird characters still there, maybe try deleting the space, or highlighting a few characters around the problem character, delete them and then re-type what you deleted.

If deleting the quote fixes the issue, then … I’d be stumped too.

Check your language settings on all devices & programs where you are viewing your text. Maybe one is set to another language, and so the quote characters are confusing the device/application.

As a last resort, maybe you can copy out a sample of the problematic text into a new document, compile it, and see if that compiles well. If not, then maybe someone can examine that very small RTF document for something that’s not supposed to be there. If it does work, then maybe copying each document’s text into your copy buffer, and then re-pasting it over the original text might somehow fix it.

I can’t say any of this will work for you, and I urge you to make a backup that you name distinctly before you embark on any more fiddling, since you could loose text easily doing any of the above.

Good (bug) hunting.

Thanks Robert. I’ll give it a try.

Maybe I was mistaken, but I thought these threads were read by the Literature support people and hoped they would have a solution for me. I emailed them directly last night and I’m eagerly awaiting their reply.

I’ve worked so hard on my book and have now missed my publishing date. You can imagine how hugely disappointing it is to schedule a book to be released for Christmas and run into a delay like this.

MimeticMouton is an L&L support person.

Thank you, Hugh.

I really appreciate everyones help.

One thing that might be quicker: In the Compile window, under Transformations, try changing the Straighten Smart Quotes option (check it or un-check it) and see if that fixes the issue. If it works, it might not be as pretty, but will allow you to get your book out. If it doesn’t fix it, then you’re out a few minutes of time and nothing in your manuscript was modified.

Worth a shot.

Something that may help tech support would be to know if any parts of your text (and perhaps the parts you’re having trouble with?) were imported or pasted from another program. If it was imported, what was the format of the imported document (.doc, .docx, .rtf, …)?

It’s possible that some of the earlier pages were imported/pasted from someplace else. I tried looking at ‘invisibles’ but nothing appeared.

I’ll dig into it again tonight when I get back from the office and try out everyones suggestions. Have no fear, I def am backing it up.

Also, I eliminated the Amazon app as the problem because I opened the same compiled file in Adobe Digital Edition and saw the same problem.

OK. An epub file is a zip file. Make a copy of the epub file. Rename the copy to have the extension .zip. For example if your epub file is MyStory.epub, copy it and rename the copy MyStory.zip. Then extract that zip file into an empty directory, for example ~/foo. Look inside the extracted subdirectory called “OPS”, that is, ~/foo/OPS. You should see a file there called body.xhtml. Open that file in a text editor. That file contains the text of your book. Find a line in the xhtml file that is displaying incorrectly in your reader. What does the text of that line look like?

Jravan, thanks. That sounds really interesting. I’ll check when I get home.

I was contacted by Jennifer with Scrivener support and she’s escalating my problem, but she feels pretty sure that it’s because I imported the text from another program.

I’m trying everyones suggestions, so thank you all and keep them coming as you think of them.

Jennifer has passed it on to me and it’s on my list to investigate. They are definitely gremlin characters caused by bringing the text in from another program - they are in the RTF - the problem is whether there’s any way Scrivener can strip them out or make them more obvious.

All the best,