Images and markdown

Hello everybody, I recently set up my workflow with scrivener, pandoc and zotero (big thanks to the user nontroppo).

However, I don’t like to have image in between my text and I prefer to have placeholder. As far as I understood I have two different ways:

  • <$Img:ImageNameInTheBinder> And here a caption as regular text

  • imageCaption

I prefer much more the second way but I would like to refer to an image in the binder and to change it if I want to. For example I have an image called Frog with a nice picture of a frog, I write my text and at a certain point I find a better picture, I would like to be able to change the first frog with the second without changing all the image links in the text. With the first method it should be easy as it refers to a name, but the second wants the link, how can I do?

Select your Binder Image then Documents :arrow_forward: Replace Media File… — this means you can change your figures without breaking the links (a wishlist item I’d wanted and was happily granted in Scrivener 3!)

this software is more amazing every day, thank you

You could also store the images outside of Scrivener and replace them (using the same name) as you want.

Scrivener will use whatever images it finds when it compiles.

[![Alt Text](/Users/UserName/Dropbox/Frog.png "Image Title")](http://bbc.co.uk/)

I thought about this but I want to use the power of scrivener keeping everything in a project instead of having a folder full of files that will be used when compile, even if it is the same :slight_smile:

Fair enough. Good to have choices.

I use images in Finder so I can swap entire sets of eBook / print-ready images at will.

I am using Scrivener to create a Multimarkdown document. I have many images stored on Droplr that I would like to insert in my document. When writing in a plain text editor, I would embed a link to an image like this:

![This is a link to an image stored in Droplr](https://d.pr/i/qGVsCl+)

And then, when I open the document in Marked 2, Marked 2 interprets this as an image and generates the following HTML:

[code]

[/code]

…which ends up displaying the image.

However, when Scrivener compiles the document using Basic Multimarkdown and passes the document to Marked 2, it does so in such a way that Marked 2 sees the Markdown image link as plain text, and instead of seeing my image, I see the literal code for the image link like this:

![This is a link to an image stored in Droplr](https://d.pr/i/qGVsCl+)

Is there a way to insert a standard Markdown image link of the form ![text](url) so that Scrivener will pass it to Marked 2 and have it interpreted and displayed as an image?

Your code works for me while editing and after compiling:

Same for you while editing in Scrivener and previewing in Marked2?

Slàinte mhòr.

Thanks for testing it, but it still is not working for me. See attachment.

Why would we get different results?

Here is what I see for the source that is generated for Marked:

<h1 id="test">test</h1>

<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Phasellus nec purus purus. Nunc vel ligula eget dui convallis fermentum. Cras elit dolor, vestibulum id tempus non, interdum sit amet justo. Morbi scelerisque mauris eu metus mattis euismod. Nam pellentesque, elit id semper ornare, ante mauris venenatis est, ac condimentum velit metus et leo. Cras erat ligula, pulvinar vel suscipit vel, tempus at augue. Aenean sem mauris, egestas vitae scelerisque eu, venenatis ac nunc. Mauris quis iaculis velit. Vestibulum feugiat mattis odio et malesuada.</p>

<p>![This is the image stored in Droplr](<a href="https://d.pr/i/3qLwSH+">https://d.pr/i/3qLwSH+</a>)?</p>

<p>Here&#8217;s the image link in plain text:</p>

<p>![This is the image stored in Droplr](https://d.pr/i/3qLwSH+)?</p>

<p>Scrivener on the left, Marked2 on the right.</p>

As you can see, no tag is generated as would usually be the case in any other Markdown document I open in Marked.

Is there some setting in Scrivener or in Marked that accounts for the difference between what you see and what I see?

Hi.

To make sure we are using the same software, please find a sample Scrivener 3 (version 3.1.1) project attached, together with the output of the same file opened in Marked 2 (version 2.5.27) and then exported as HTML

For this test file, Marked is giving the following HTML for me:

[code]

Scrivener 3, version 3.1.1

Marked 2, version 2.5.27

A few words of text.

This is a link to an image stored in Droplr

And some more words.

[/code]

The image loads without issue.

Struggling to find a setting that would explain the differences we are seeing. But still looking…

Slàinte mhòr.

Test.zip (100 KB)

I tried your file, and it worked perfectly. I copied a link from my document which does not work and pasted it into your test file, and that worked perfectly too.

I noticed your test project was based on the Novel template. Mine started from a blank template. I wonder if that has something to do with it???

To investigate that, I created a new project based on the Novel template and copied several of my problematic documents into it. They all compiled into markdown and displayed graphic links in Marked 2 just fine. Very strange!

I have defined several custom styles in my problem project, but even I remove all the style settings from a document, it still does not compile and display correctly.

One other possible clue: In my original document, when I bold or italicize the rich text, Marked picks this up and displays the text in bold or italics without me having to add Markdown syntax (i.e., “**” or “*”). The same goes with paragraph breaks and spacing. I don’t have to add an extra line of space between paragraphs. Interesting this is not true of the document you sent me. In that document, I do have to explicitly add the Markdown style syntax. I definitely think this is a key difference between your test document and my problem document. Now I actually prefer my problem document except that I cannot get it to export image links correctly.

Does any of this suggest to you a possible explanation?

Cheers!

Problem solved: In the section layout definition within the compile settings, I had Convert rich text to MultiMarkdown checked. While this is very nice in terms of converting things like RTF bold and italics to ** and * in Markdown, it causes image links to be treated as plain text. By unchecking this option (see d.pr/i/9adIf3+), the images now are passed successfully to Marked 2.

Just seen your two posts. Glad you found a solution. Thanks for sharing – might help others in the future.

Slàinte mhòr.