Images cut off in ePub when viewed in iBooks

Howdy friends.

I’m a recent convert to Scrivener and I’m having a bit of trouble with images displaying properly in iBooks when I export my document as an ePub. I’m using Scrivener 2.4.1 on a Macbook Pro running OS X Mountain Lion10.8.4.

(Permit me a brief introduction to how this document came to be, just in case its relevant…)

The document I’m working with started its life as a series of MultiMarkdown text files (one file per chapter). I’ve imported several of them using File > Import > MultiMarkdown file. Because most files included a series h3 elements, they were broken into different files, which I subsequently merged back into one file per chapter.

All of the images I’m dealing with are screenshots (PNG files) of disparate sizes and shapes. A handful of these images are rather small, less than 200 pixels wide, and those render as expected in iBooks. The rightmost edge of the remaining images is being cut off when displaying in iBooks and I’m not sure how to mitigate this behavior.

Here’s what I’ve tried:

  • Resize the images in Preview.app such that they’re smaller than 300px wide. This does solve the cutting-off issue, but the resulting image resolution is so low that the images are grainy and difficult to decipher when viewed in iBooks.
  • The image tag (e.g., <$img:MyImage;w=300>) business works the same way as if I drag the images into the editor pane — the images are still truncated when viewing the document in iBooks.
  • Changing the point size of the image (right-click the image, Scale Image). This doesn’t seem to change the underlying resolution of the image itself, but rather the quality and clarity of the image at compilation time.

I’ve read through the relevant sections of the Scrivener manual, but have been unable to find a solution.

Here’s what I would absolutely love to happen, if possible: drag an image into the editor pane from the Binder. When the compiled ePub is rendered in iBooks, have the image scaled down such that the entire image fits within the bounds of the text area. Double-tapping the image in iBooks would zoom it into focus, as it does now.

If anybody has any suggestions as to how I can get around this, I’d be extremely grateful. Thanks!

Check your images and make sure they do not have a paragraph indent. In my experience iBooks will resize a graphic to the width of the display as necessary, but it gets confused by paragraph indents—it will not calculate the indent as being a part of the image width, and cause part of the image to be cropped off of the display.

Forgive me, but how do I remove paragraph indent from images? I’ve looked through the preferences, but I’m not seeing where to configure this.

Thanks much for your response!

Figured it out. Here’s how you do it in case anybody else finds this thread:

  1. Enable the Ruler (Format > Show Ruler)
  2. Place your cursor before or after the image
  3. Drag the little Paragraph Indentation all the way to the left to remove the indentation (see screenshot).
    EEv4_-Sync__Huh.png