Import & Split, extra line break in 1.7.2?

Edit: Crisis averted. I set the text separator field to blank and I can output as expected. But it seems something’s changed somewhere, or I would have had that saved into my compile presets from the get go.

It appears that Import and Split is adding an extra line break as of 1.7.2

Here’s a sample line done with 1.6.1 (or whatever it was):

Here’s the same thing, done today in 1.7.2:

The above screen shots are from Scrivener, the ones below from Word

The result of which is when I compile out to Word it’s now essentially double spaced (and the client requires single spacing):

Before:

After:

I’m open to the possibility that I’ve merely stuffed it up somewhere along the line, but as far as I can tell I’m using the exact same settings.

Thoughts? Work-arounds? Fixes?

Thanks, this seems to be a bug introduced by changes in 1.7.1. I’ve filed a report. Meanwhile you can work around it for the most part by adding carriage returns around the separator character in the import & split dialog. In my testing, that worked to get the 1.6.1 results with the exception of the final document in the split, which still has an empty line at the bottom you’ll need to manually remove.