Imported Word Doc/ RTF loses formatting at each page break from the original manuscript

I’m attempting to move a manuscript in Microsoft Word over to Scrivener, and am finding that there are formatting issues at every spot where there is a line break in the word document.

Basically, I’m forced to scroll through each scene, then hit backspace/return to get rid of added lines and/or fix some paragraphs that are randomly split into two paragraphs in mid-sentence because in the word doc there’s a page break in the middle of it.

Here’s a photo example! image|690x192

I tried converting the Word Doc to an .rtf but had the same issue. Is there any setting I can change in Word or in Scrivener that will allow it to read each scene as just text, and not be tripped up by page breaks?

One more detail that may be relevant is my manuscript was actually ORIGINALLY compiled from a Scrivener 1.0 file in manuscript format. Tragically, during some computer issues earlier this year I lost the scrivener file, but retained the exported manuscript (which fortunately I’d backed up). I’m hoping to wrap up revisions on the project in Scrivener again, but given it’s quite a long document I would very much like to avoid having to worry about random paragraphs being split up as I go through it.

I’m using Scrivener 3 (now that it’s out on Windows) and Windows 10.

Thanks so much to anyone who can provide some assistance!

First step, turn on the invisible characters so that you can distinguish between new lines and pilcrow marks (paragraphs). Without those little critters it’s harder to tell what’s going on. Then check the formatting for lines and paragraphs re how much space you have told Scrivener to put between lines and paragraphs. Also, you might like how it works when you use Menu: Edit → Paste and Match Style so that the incoming text takes on the format of the Scrivener target.

That could be a good clue. Back in the day, it was a lot easier to type in a line break character, to the point that we suffered with the consequences of accidental insertions of them, in support, for years. The shortcut was made more difficult to type in, and the problems went away.

Thanks for the suggestions!

I turned on hidden characters, and there seems to basically be two versions of the problem. One is paragraph markers which are not being read as line breaks (like in my original example). The other is that, at each point where there is a page break in the manuscript, there seems to also be a line break hard-baked into the Word Doc/ RTF. Unfortunately, it seems the images aren’t embedding in this reply, but hopefully that makes sense.

This persists with the suggestion to “Paste and Match Style,” which suggests the problem is likely with the way the Word Doc is formatted in the first place. Could be a strange hangover from early Scrivener compile settings, or just a strange quirk of my file.

Any other suggestions are welcome, but worst-case I’ll just go through and fix each of these as I do my next pass of revisions. Invisible characters are a big help at spotting these instances at a glance, so thanks for that.

Yeah, if you’re talking about the difference between and in invisible characters, then that’s not a formatting thing. Those are actual characters, just like the letters that you can see which form words. No amount of stripping formatting is going to delete or change literal characters.

But, characters are exposed to handy tools like Search and Replace. :slight_smile: So that may help you out a fair bit, particularly if you don’t really have any style line breaks that you really do need.

So there actually don’t seem to be any :leftwards_arrow_with_hook: style line breaks (or clicking "Show Invisibles didn’t show me any).

Basically what’s happening is the doc is double spaced right now (since the original manuscript is), but a sentence will stop midway through (exactly where the page break happens in the original doc) and then there will be a single-spaced ¶ hanging on the line immediately below it. Then the sentence picks up on the next line, double-spaced as normal, and carries on mostly fine until the next page break, where the same problem pops up again.

But even if I can’t search and replace, worst-case scenario it can happen manually. Was just hoping there might be some kind of tool that can resolve the issue, seems as though the problem exists in the original document as you said, so no amount of formatting will resolve it.

Thanks again for the help!

Have you checked the format for each of these paragraphs (for paragraph and line spacing)? That is what controls what you are seeing. Put cursor on a paragraph, click, Menu: Format → Paragraph → Line and Paragraph Spacing. Each paragraph might be different. Look at each that are a mystery to you.

(Note: this same concept of line and paragraph spacing is in Microsoft Word, so should not be new to you)

Yup, I tried this first!

The whole project appears to be set to before/ after paragraph 0.00 pt, line spacing double at 0.00. There don’t appear to be any changes where I’ve got the problems – it does seem to have been caused by additional ¶ s that were somehow baked into the original Word Doc.

Sorry, but that doesn’t ring true to me as pilcrows (paragraph markers_ are valid characters and used universally in documents, but maybe … won’t object if I learn something today.

How about

  • select all, cut, Menu: Edit → Paste and Match style

or

  • pick the item in the binder, Menu: Documents → Convert → Text to Default Formatting

Okay, I think we’ve solved it! Thanks so much to everyone for the advice in this thread.

Basically, “Paste and Match style” did fix my initial problem, which was the weird line spacing (convert text to default formatting gets the same result, thanks for pointing that one out too).

But it didn’t resolve the sentences broken up by floating pilcrows. However, since each line ended with ¶, and then all the “extra” line breaks were just “¶” I was able to to do a search and replace for “¶¶” and replace it with a space, which seems to have fairly seamlessly resolved the problem! I’ll go through and make sure this hasn’t broken anything else later today, but it seems we’re all set.

Thanks again to everyone, you’ve saved me literally hours of painstaking work.

3 Likes

Well done. Now an official/accredited Data Munger!

1 Like