Imported Word file Problem with Excel Table

Hello,

I couldn’t find related topic so here I am. Sorry if there is such a topic somewhere else.

So I use MacBook Pro. OS X Yosemite Version 10.10.1 and scrivener version 2.6 .

Step by step:

1- I imported a Microsoft Word file to scrivener by using add–Existing Files.
2- There were Microsoft Excel tables inside of the MS Word file and I wanted to re-arrange those tables by dragging outlines. And of course I was trying to do this after MS Word imported and in Scrivener editor.
3- Just after the dragging outline attempt Scrivener has been freezed. I was not able to switch among text files or folders in the binder. In the mean time even if I could click files or folders in binder scrivener was not displaying any document in the editor. Only option to display text file was to use quick reference option.
4- I tried to re-generate problem 5 times. And each time I’ve experienced it.

Thanks for explanation.

Gökdağ

Hmm, that’s interesting. If I understand you correctly, in that when you say “freeze” you don’t mean a full hang or crash, but a state where the software isn’t reacting to Binder clicks the way it should—then we know of a similar symptom for another bug entirely, and I’m wondering if they are related. Could you run this same test with a blank project, only this time leave Console open in the background, and copy and paste any messages from Scrivener into your response.

Also, you may wish to go through the article on this other bug. Like I say, it’s about PDFs which have literally nothing to do with imported Word files, but there is one binding factor between the two: we believe the problem has to do with tables in PDFs.

Hi,

I tried again and have experienced the same problem. As you re-phrased it’s not a complete hang or crash.System is not reacting to binder clicks.I’m not importing PDF file but word file with tables within.

Console messages in pdf format has been enclosed. If it’s not readable I can copy and paste directly on message body.
console messages.pdf (669 KB)

Yes, I do realise you are not working with PDF, I just wanted to double-check to make sure that the underlying bug, which could theoretically impact things other than PDF, was the same. However upon examining the console logs (thanks for that), it doesn’t appear to be a problem with Accessibility.

Here is what I would try next:

  1. In Scrivener’s Import/Export preference pane, at the very bottom, disable the enhanced converters option.
  2. Drag the Word file into a test project.

You may notice formatting problems with it, that is okay, this is just a diagnostic test, you can change it back when we’re done. But what we’re testing here is whether it is a problem caused by those enhanced converters, or if it is a problem with the tables themselves once they are converted to Mac tables, no matter the origin.

If that continues to freeze Scrivener, then the next thing I would test is to save the file from Word as RTF and drag that into Scrivener instead (RTF is a native format for both Word and Scrivener, so this test removes all complexity caused by conversion between word processing formats). Does that work better? If not, then try opening the RTF file in TextEdit, the free Mac editor (which also uses the same text engine Scrivener does). Do you have any problems with tables in TextEdit?

You’re going to want to leave Console open for this as well, to monitor for messages from TextEdit, and make note if it dumps out a bunch of stuff that looks very similar to what you see in the attached PDF.

Thanks for instructions first of all. After disabling enhanced converter option I did not experience any abnormality. I tried by adding as well as dragging the file. Console log is also enclosed. Although console gave “The ShareKit framework’s library couldn’t be loaded” warning. I assume it’s because I disabled the converter which uses this framework?

How can we solve the problem by re-activating the converter option?

Thanks.

Gökdağ
console_log2.pdf (24.7 KB)

Okay, that’s interesting, it could indicate a bug in the Aspose converters we use, but it might also be Aspose is doing this absolutely correctly, but in a way that the Mac text engine does not like. Either way we do no make these converters ourselves, nor do we make the text engine, we are merely hosts in this conflict between the two. :slight_smile: We’ll see what we can do to make both parties aware. It would help if you could send a sample file with a table that causes the problem on import. Feel free to use my e-mail or PM links to the right of this post.

For now, did you try converting to RTF with Word, using Save As, and then dropping it in Scrivener? As I mentioned before, this method does not require any converters at all, as RTF is a native format for Scrivener and Word.

Hello again,

I dragged and dropped RTF file and did not experience and abnormality again. It’s probably about MS Office for Mac but of course I can’t be sure.

I’m also sorry that I didn’t understand what exactly you wanted from me. What kind of sample file with a table do you refer to?

Thanks for your help again!

Gökdağ

I’m fairly certain the root problem is the use of embedded Excel spreadsheets. These spreadsheets must be converted to word processing tables, and it seems this is where the problem starts; that potentially our converters do not properly handle these embedded spreadsheets. When you saved it as RTF from Word, MS Word did the conversion itself, and Microsoft is going to have a much better time of converting their proprietary and convoluted formats around.

Well you evidently have a .doc/x file with a spreadsheet in it that makes a mess when you drop it into Scrivener. If you send me that file, then I might be able to make a mess with it to, and if I can, that means it is likely that Aspose, the maker of the converters, can figure out what is going wrong. So if you have a file you can share that would be great. Otherwise there is no way for us to confirm your report. I myself have had no luck even getting a .docx file with an Excel spreadsheet to import a table at all, let alone a table that will crash the software. I was surprised to hear that the Aspose converters even handled them for you.