Importing and Exporting Files

I’m using the trial version of Scrivener for Windows. I am unable to import .doc files (it says the conversion engie for doc and docx to RTF has stopped working). I am able to import .rtf files, but when I try exporting them again it says “error …” I am able however to export files that I create in Scrivener

Any ideas?

I am also using the trial and I got “Out of Memory” errors on all of the .doc files I tried to import and something different on my .txt file. None of them imported the first time.

After I tried to save a couple of hours of work (which appears to be lost now) and got strange missing text, I restarted the application.

The files now appear to be importing as they should, but I am still wondering where my new text went.

Sounds like a few different things going on here (though possibly related)…

  1. Import - This will be handled differently depending on whether you have Microsoft Word installed. Could you let me know whether you do have that program installed and, if so, what version it is? I’m assuming these are files that you created outside of Scrivener and are importing for the first time, but if they’re files that you originally exported from Scrivener and are now re-importing, that could also make a difference.

  2. Export - What file type are you trying to use for export? That is, you should be able to select, for text documents, from the drop-down menu in the Export window. Are you exporting to RTF or choosing something else like DOC, PDF, etc.? There was a bug relating to non-Scrivener created files not exporting as anything other than RTF, and fixes for that may have inadvertently caused another issue, or I may be crazy and this hasn’t been fixed yet for the 1.0.3 release, in which case it may be the same bug you’re seeing.

  3. Yoha, re: import/missing text - I’m assuming this is the synopsis text that you mention in a different thread specific to the missing text issue, so we’ll continue working with that over there, but I just want to clarify then that the text that went missing was typed in Scrivener and not something you’d imported?

If either of you has the exact wording of the error message you received or a screenshot of that, that would be helpful to see. Also, could you let me know what versions of Windows you’re running and what version of Scrivener (Help > About Scrivener)? Is your project (that you were importing to) stored on your local drive or on an external or networked drive?

  1. I am using Word 2007 and Windows Vista Home Basic (running service pack 2). I am using a Intel Dual core 2.20 GHz with 4 GB RAM on a 32 bit system.

I am using the trial version of Scrivener for Windows, version 1.0.3, with plans to buy it if I can get this working.

Yes, the files are created outside of Scrivener in Word and are in .doc format. I am importing from a local drive, not a network.

  1. I was trying to export it in .RTF. Using .doc would be ideal, but either one would be good. My daily routine (if I can get this working) would be to write during the day at work in .doc, come home, import changes into Scrivener, do some editing, and export back into .doc for the next day.

  2. The Error 1 screenshot is the first thing that pops up when I try to import from .doc
    Error 2 is the next window that pops up.

  3. Importing the file when saved as an .rtf works fine, but when I try to export it back again in .rtf i get Error 3. I do not get this error when I just type something into Scrivener originally and then export it.

If you need any more information let me know.



It looks like it posted my screen shots in reverse order. go by the file name of the screenshot.

Thanks for the extra details. It definitely looks like the doc2any converter (for importing .doc and .docx files) is throwing a fit, although I haven’t managed to get it to do this on my computer yet. I’ll pass this on to Lee; we may have to take out a ticket with the doc2any folk to get this sorted, but maybe it won’t be as messy as that. In the meanwhile, the solution is probably just to save your files as .rtf and then import them that way, since you’re able to do that without getting the error.

The export error looks like a bug, probably related to the previous bug of being unable to export imported files in anything but RTF, so hopefully that won’t be too difficult a fix for the next update. I was able to replicate that one without trouble. I’m able to export successfully in other formats though, e.g. as .doc, so you might want to try the same. Just choose something other than RTF from the drop-down menu in the export window and see if you’re able to get it out properly.

Excellent. It works exporting in .doc and importing in .rtf, so I’ll use that system for now until we figure out what an actual fix is.

Thanks!

Good, glad you at least have a workaround for the moment. Would it be possible to get a sample of a .doc file that you’re getting this import error with so Lee can try and reproduce the issue on his own machine for debugging? You can send it to support AT literatureandlatte DOT com.

yoha - It sounds like you’ve been able to get the import working, but just to follow up with that since apparently I didn’t in the earlier post, “Out of Memory” would be an OS warning, so if you get that again it’d be good to take a look at how much available memory you’ve got at the time, what other applications are running, how large the file you’re trying to import is, etc. Task Manager should be able to provide the specs on most of this.