Importing text

I’m in the first week of the purchase and started by trying to import text from microsoft word processor docs or open office docs, to no avail. When the browse window opens and I try to find the docs, nothing appears available. Please help me understand this. I was so excited to get started and I can’t! It does work to copy and paste, but that’s so time consuming. I wanted to choose a file and drop it into the program.

You should be able to just drag the doc file from your MS explorer directory into the Scrivener binder. The MS Doc file should then import automatically.

This certainly should be working, so I might need some additional details to figure out where the chain is breaking for you. If you have a project open, you should be able to select an item in the binder (e.g. select the Draft folder) and then choose File > Import > Files… or File > Import > Import and Split… and be able to choose a .doc or .docx files to import as a subdocument (or subdocuments, if splitting) of the selected binder item. DOC and DOCX files should be able to be imported to anywhere in the binder (vs. media files, for instance, which won’t be accepted in the Draft folder, since that’s intended for compile and only text documents compile) so I’m not sure why it would be getting greyed out for you. Have you tried quitting Scrivener and then reloading the project to try again? Maybe something got buggy in the session earlier and refreshing will fix it.

I’ve been having the exact same problem with my trial version. I have a large, incomplete and very disorganised draft created in OpenOffice. It didn’t show up as an .odt file in the Browse window after I’d set up my Srivener project, selected Draft and went to import. So I saved the original version on my hard drive in .doc format instead. No joy. Then I saved it .rtf format. Still no joy. The only way I could import my text was by selecting it (takes forever with a large word processed file), copied, pasted into Wordpad, renamed it to save it, and then it showed up in the Browse window. Then I had to delete the now superfluous renamed file on my PC. Why is the process so cumbersome?

It’s makes me a little nervous, as I’m finding Scrivener difficult to get to grips with anyway, and the terms used in the tutorial and manual don’t always make sense to the layperson.

The process shouldn’t be so cumbersome; as I said above, it should be possible to import a supported text file anywhere in the binder, so there is something going wrong when you’re trying this, but without more details or the ability to reproduce the issue, I’m a little at a loss to know what specifically is the matter. ODT isn’t supported for import, so you will need to resave that to .doc or .rtf, but either of those should have worked for import. Was it only this particular file that didn’t get recognised when saved as .doc or .rtf out of OpenOffice? Normally that’s not a problem at all, so I wonder, if you’re still unable to import that specific file into a Scrivener project, could you send it to AT literatureandlatte DOT com so we can test with it? (Reference this forum thread in the email.) If you just drag and drop that file into the binder, instead of going via File > Import, does the document import correctly?

I did try drag and drop in Windows Explorer, but nothing happened. I tried to do it by jiggling between the open Explorer and Scrivener windows, but I couldn’t line everything up.

Thanks for the offer to look at the file I imported (I assume that’s an offer to me as well as HediHO), but this is my WIP, and at it’s very personal to me, especially in its raw state.