Inability to select Charter font

This is a kind of weird one.

So: I want to use a custom font, Charter, with Scrivener. It’s in my Dropbox/Apps/Scrivener/Fonts/ folder, along with Source Code Pro. (Source Code Pro was my default text font on the Mac and iOS until recently, when I changed it to Charter.) On the Mac, I’ve changed the “new document” default under Formatting in Preferences to be Charter, and have used “Export to iOS…” in the Format menu to save a presets.plist file to the Dropbox sync folder.

When I open my current project, the existing documents in the manuscript in Charter display correctly, and if I bring up iOS’s formatting palette, it correctly says the font is “Charter 16pt.” But…Charter doesn’t appear in the list of selectable fonts.

Earlier today I created a new document in the project and it came up in Source Code Pro, and there was no way to change it to Charter. “Apply Default Formatting” didn’t work; “Copy Format” from text in Charter and “Paste Format” didn’t work. Just now, when I created a new document in the project as a test, it did come up in Charter. But the font still isn’t in the menu.

I’ve tried putting the font files in the Fonts folder, in a subfolder of Fonts named “Charter,” tried importing each one (regular, bold, italic, bold italic) manually into Scrivener (and been told each one was successful), and even added the font to the system with AnyFont—other fonts I’ve added that way seem to be picked up by Scrivener without issue. But not Charter. Nothing makes Charter show up.

I may just give up and go back to Source Code Pro or Triplicate; this isn’t really a burning issue in practice for me. But I’m not sure if it’s something peculiar to my environment, or if it’s a bug specific to this typeface. Somehow. Any ideas what might be going on?