Include in Manuscript - Can't unmark it.

Hello all,

I got a new text inside the research area. The inspector makes a mark in the “Include in Manuscript” option, which I don’t want. But I’m not able to unmark it, because it is locked.

Am I missing something?

Thanks,

Marcus
image_067.jpg

All checkboxes in the Research area are greyed out and not clickable. This is obviously done on purpose - and when you compile your draft no research files are offered for including anyway.

Ah, ok, thank you.

Then it seems like having that box checked is a tiny bug–shouldn’t it be permanently unchecked?

Yes, this was my first thought, too. I think it is a little bit confusing.

No, it’s not a bug. The “include in draft” flag is an internal flag which is set to ON by default for all text documents. But it only has any meaning if the text file is actually inside the Draft folder, so the button is greyed out in the inspector if the document is not in the Draft folder (you can still toggle it in the Outliner, though it has no effect). Were you to move the document to the Draft folder it would thus be included by default, as you would expect, and you would be able to edit it via the inspector.

It is mentioned in the Help file under Meta-Data why this is greyed out.

Thus, expected behaviour.

Regards,
Keith

Oh, FINE. 8)

Thanks for your explanation.