Include Inspector Comments in Compile

I’m using Scrivener 3 and have been unable to figure out how to include Inspector Comments in Compile. I’ve gone to Compile>Footnotes & Comments, and have tried using the “Export comments and annotations as” dropdown to export as Margin Comments, Inline Comments, and even Footnotes but haven’t been able to successfully compile with the comments in any format. I’ve tried compiling as .docx, .doc, and .rtf, and no dice. I feel like I must be missing something obvious.

In the first compilation dialogue (ie the one you get when you start compilation, not the edit screen), at the top right, there are several icons, including a ‘gear’ (second from right usually). If you click on that there are several options, including to Remove Comments / Inline Annotations. Have you checked whether they’re still ticked (they are by default, so comments are not usually included in the compile). If they are, then untick them both.

That’s the first thing to try — if it doesn’t work, please let us know. HTH.

Thank you!!! I had not located that menu. That worked perfectly!

I’m having a similar problem, but the suggested solution is not helping. I have tried to compile the file both to docx and rtf with no success regarding comments. On docx, I get a message from Word that the file is corrupted. On rtf, the comments just don’t come up.

I also tried importing into Google Docs and I just get the message “Invalid link” wherever a comment should be.