Inconsistent display of Synopsis information in the Inspector (and no Synopsis editing when it happens)

I’m setting up a template with a binder structure including number of categories, some of which have sub-entries, each entry has a Synopsis description. I’ve found an issue whereby sometimes I can see the ‘higher level’ synopsis in the Inspector, but often, if I select a sub-category in the binder and then return to the higher level, the Synopsis displayed is always the last sub-category I selected and not the currently selected one in the binder. Sometimes I can get the correct synopsis back in the Inspector by changing the view via the scrivenings/corkboard/outliner button but often if this occurs, I cannot then edit the synopsis - sometimes there is a cursor in the synopsis text (placed where I click) but it can’t be moved with the mouse or keyboard (inside the synopsis text area) - other occasions there is no cursor in the synopsis text and you can’t do anything other than click somewhere else in Scrivener away from the synopsis to get response back.

Scrivener 3.1.4.0, Windows 10 22H2 build 19045.2546

It’s not really affecting my work but it’s a bit annoying in trying to get this template set up.

I have seen incorrect behaviour when using some forms of non-binder navigation, such as the history buttons in the editor (click on container A, double-click on card B icon, click Back button: should be card B inspected since that is what is selected on the corkboard, but instead container A is inspected).

I don’t know if I have seen what you describe though, precisely, even though it sounds similar. What would help us a lot is to put down the problem into a step-by-step description, using the software’s terminology to describe what you’re doing (I don’t really know what a “sub-category” is), up to the point where it stops working the way you expect.

I tried following your description, but I’m probably doing something wrong because I don’t have the right view mode selected to start with, or haven’t click here or there first, etc. So much as whether your had the cursor in the inspector before navigating elsewhere might matter, you see.

Ha! Hi Amber, thanks for getting back, :smiley: I spent a fair amount of time before I wrote this trying to tie it down to a repeatable sequence but not succeeded in nailing it down consistently.
Lets see if pics help, at least to describe the inconsistent display of Synopsis info…




Capture1 - loaded up Scrivener and clicked on Wiki category in the Binder, the correct synopsis and note is shown in the Inspector.

Capture 2 - Clicked on Character sub-category under the Wiki - the Inspector shows the synopsis and note associated with the Character category as I’d expect.

Here seems to be the start of the problem - if I return directly to the Wiki category, sometimes it shows the correct Wiki synopsis, if however I edit the Character Synopsis then… then click on Wiki…

Capture 3 - Clicked on Wiki again in the Binder, the inspector still shows the synopsis for the Character category (and I note it remains selected in the outline)

If you click on the Scrivenings/Outlline/Corkboard button it will usually re-display the correct Wiki category synopsis…

This seems to be repeatable. Now, if only I can figure out a way to get it to show the edit problem consistently too!
Mostly it happens at the Capture3 pic stage. Have a feeling it might have something to do with ‘Character’ remaining selected (as shown in the in the outline) although Wiki is/should be the current focus entry?

Many thanks for the additional details.

Capture 3 - Clicked on Wiki again in the Binder, the inspector still shows the synopsis for the Character category (and I note it remains selected in the outline)

Ah! Well in that case this is to be expected. Try looking at it another way, and interact with the Outliner list in the editor a bit. As you click on different sub-categories in here, they are inspected. Pretty useful, right? It would be kind of annoying to have to fully navigate into a document just to inspect it.

So if you have a selection in the corkboard or outliner, it’s going to remain when you return—because again from another perspective persistence is good and having to reselect every single time you come back to a view would be annoying—and by remaining it means you would be inspecting that selection, not the container.

To do that, all you need to do is deselect (which also is a persistent condition), which you can either do by Ctrl-clicking on the selected thing, or perhaps in a more universally simple fashion, with Edit ▸ Deselect All.

Now, what you are observing by toggling through view modes is funnily enough a bug. When you switching between view modes it should not disturb persistence, and in fact it should carry your selection through seamlessly. Select “Creatures”, switch to Scrivenings, and you’ll be scrolled to it. Scroll to “Characters”, switch to Corkboard, and “Characters” will be selected—and all the while the inspector remains fixed on what you’re working on through your usage of views.

So perhaps some of this variability you are experiencing is down to some known bugs and issues with persistence and selections not working how they should—and maybe a dash of that one bug I mentioned before, where some kinds of navigation events can break all of the above, and you end up with “Characters” visibly selected in the Outliner, but “Wiki” ends up getting inspected—which might have helped inform your expectation that it should work otherwise, regrettably.

Now what we wouldn’t want to see is a case where clicking on “Wiki” continues inspecting “Characters”, and characters is not selected in the corkboard or outliner. That would be a bug—but I haven’t encountered that one myself if it is out there. Like I say I usually have seen the opposite: something is selected but not inspected.

I’ve just tried the ‘Deselect All’ menu action and it didn’t appear to do anything - at least I thought so at first - as selecting the Wiki then Characters categories was still goosed after doing it (at least IMO! :laughing:) showing only the Characters Synopsis in the Inspector. I then changed views and it reset.
but… I then put an arbitrary edit into the Characters synopsis and clicked on Wiki expecting it to not display but lo and behold, the Inspector synopsis switched to the Wiki’s entry… I’ve now been through other categories under the Wiki (and other Binder categories outside it - also editing a couple) but reselecting it afterwards, and they and the Wiki entry now behave as I would expect frankly.
Maybe the Deselect action on the menu cleared out something unexpected/persistent from previous sessions?

Anyhow it all seems to be working now (at least as I think it should) so all good on that front and I can continue the creation of this Template without the occasional ‘Grrrrrr’ when I can’t refer to the Wiki Synopsis and notes without switching views.

Many thanks for your response on this.

1 Like