Inconsistent Numbering on .docx and .pdf

After setting main body header and footer to start after front matter and unselect page numbers to count first pages, I added <$p> on footer for Main Body.
When compiling to pdf, everything works as expected, but when exporting to .docx it just starts from front matter first page.
Am I missing something? Some other configuration?

Did you repeat the procedure to set this up when you switched from pdf to docx output in compile?

Yeah, they have the same settings both on PDF and DOCX.

Could you post a screenshot of your Scrivener -> Preferences -> Sharing -> Conversion pane, please?

Katherine

Hi Katherine,

Here it goes:

Not sure of what this config means.

Thanks,

Try unchecking the “enhanced converters” box. We’re testing a different conversion tool that may give better results.

Katherine

That did the trick. It’s working fine.
Thanks Katherine.

Just a last question: what’s the difference between RTF-based .doc and standard macOS export options?

The “RTF-based .DOC” option simply takes a standard RTF file – Scrivener’s native format – and puts the .DOC extension on it. This option dates to the early days of Scrivener. It gives acceptable results for simple documents, but I wouldn’t recommend it for complex projects.

Katherine