Indent gets lost after ending a list (in editor, not compile)

As noted in a previous thread:

This is an unfortunately side-effect of how OS X handles lists.

It’s not something we have any control over. The given approach in that thread is now out of date so ignore that. What you have found is the right way to do it now: hit the ⌥⌘0 shortcut (for Format ▸ Styles ▸ No Style) to revert the current empty line you are on back to the default formatting, which would include an indent (among any other shifts in settings) from the sound of it.

This is also a useful tool when working with styles that continue automatically when pressing return. It’s a way of backing out of any custom formatting environment and returning to normal—similar to how one would use a “Normal” or “Body” style in a word processor.