Indented-List ePub Irregularity (Easily Reproducible)

Step 1: I start with some sample text.
image
Step 2: Now I set the middle 3 paragraphs to List, using the Format bar icon, image I also set the spacing to 1.0. image Looks about right. A little too much spacing between the dot and the indent, but there’s nothing that can be done about that. (Right?)
image
Step 3: This is what the compile to ePub looks like. (Too much indent, but otherwise okay.)
image
Step 4: Now here’s the problem. I go ahead and make these 3 paragraphs into a Style. (Format => Style => New Style from Selection) Then run the ePub compile again and this is what it looks like. Not nearly right. I also did compiled to a PDF and that looked fine.
image
For the time being I can just NOT use Indent-List as a Style, but since I spent so much time trying to figure this out, (Running over a dozen tests), I thought I’d report this issue.

1 Like

Thanks for the report!

So there are a few compounding problems (all known and filed as bugs), some of them upstream from lists, but something to be aware of is that lists in ebooks aren’t intended to be WYSIWYG. The appearance of lists is meant to be solely driven by a centrally defined CSS, which you can either do yourself or select from one of the presets by double-clicking in the “Ebook” format in the left column of compile to edit it, and then in the Tables & Lists pane, select the marker styles you want. The stock Ebook compile format has quite a bit of formatting for lists already done for you, and you will note that this pane really only concerns itself with marker styles, not indents.

Those are something you can change, with your own CSS, but it’s meant to be something centrally driven rather than something you have to labour over each list in the editor with.

Where things get messy with that though is that the compiler is trying to put additional formatting on top of the list, which messes up the fine-tuning in the stock CSS. Here is what a list should look like:

<ul>
<li>List line one</li>
<li>List line two</li>
</ul>

Instead we get something like this:

<ul>
  <li class="ps2">List line one</li>
  <li class="ps2">List line two</li>
</ul>

In a simple test using default settings and no formatting adjustments anywhere, the .ps2 class looks like this:

.ps2 {margin-left: 3.00rem; text-indent: -2.08rem}

That is all kinds of wrong, and actually looks worse than what you have, so I don’t know if there is something else going on that you’ve done to mitigate the default output. Whatever the case, if I delete that line from the stylesheet.css in an ePub editor, I get something much better. It doesn’t look anything like the editor, but again, it’s not supposed to.

At the moment, that’s actually the best solution. Compile, open the .epub in an editor like Calibre of Sigil, find the “.ps#” class that is being assigned to lists, and delete it from the stylesheet.css file. Naturally, that’s the kind of thing you may want to save until the very end, and put up with weird formatting during initial proofing.

I use Scrivener to produce Kindle documents, however, whenever I use bullet point lists the first line of text is not indented and overwrites the bullet symbol. I attach a photograph of my Kindle paperwhite displaying a document generated by Scrivener.

Is it possible to correct this anomaly?

I am running Scrivener Version: 3.1.1.0 (1463331) 64-bit - 03 Nov 2021
On Windows 10 Pro 21H1 (19043.2006)

I’ve merged this post with a very recent thread on the same topic. Note the original poster has a different result than you do (and what you see is what I get as well, I’m not actually sure how they go their result). I note a solution (manual fix) in the last line of my post above.