Index Card Font and Size [BUG LOGGED]

I just tried to change the index card font and size for both the title and the text, and it doesn’t take the change. It always goes back to the default of Courier 12 pt for the title and 10 pt for the text.

It also won’t take a font for the stamp–always stays Helvetica. Even when you’re still in the preference settings and switch the font, hitting “apply” does nothing, and once you exit the options and return, they’ve reverted as the OP states.

(XP Pro SP3, beta 1.9)

I’m able to change the font size/style on Index cards.

I can do it by going to Edit>Options>Corkboard. I can change the text size, change it to bold or italic, and to a different font. I change it by hitting Select. After I choose my font/size/appearance, I hit OK, then Apply, then OK. The window closes out and the change is visible on the index card.

However, I CAN’T change the text if I go to Edit>Options>Appearance>Font Setting>Index Title or Index Text. I am hitting Select Font, changing the font, then hitting OK, then Apply, then OK again to close out the window. Even though it shows my new font selection, when the window closes, there is no change. Then when I go back to the Appearance tab, my selections have reverted back to the default settings.

So I can change the font and size by going to the Corkboard tab under Options. But I can’t change the font and size by going to the Appearance tab under options. It will say that it has changed, but it doesn’t change when I view the index card.

I tried changing the font/size numerous times and every time was able to change it by going to the Corkboard tab under Options. But I was never able to change it by going to the Appearance tab under Options.

I’m running Scrivener version 1.9 on Windows 7 Home Premium.

Hope that helps!

I forgot to mention, that I can also change the status stamp as well.

Again, I have make the change under the Corkboard tab under Options. If I try to change it by using the Appearance tab under Options, nothing happens. It will say the font has changed, but no change is visible on the index card, and when I go back to the Appearance tab and check the font, it has reverted back to the default settings. However, I’ve been able to change it numerous times under the Corkboard tab.


Ack, sorry, yes, I completely missed saying that. ::facepalm:: Only had these troubles trying to alter the font under the new “font” settings of the Appearance tab; no troubles under Corkboard.

Might be worth mentioning that you won’t see a change to the index card text if you have ‘Use small fonts’ ticked (had me scratching my head for a few minutes).

Also, while playing around with changing fonts, it’s just occurred to me that it’s odd that you’re able to select a font size for the status stamp text. The text gets resized to fit the card anyway so what’s the idea of selecting a font size for it?

If you select the smallest size, apply it then select the largest size and apply it you do see a slight different (mainly in the spacing/kerning) but basically, it’s the same. Am I missing something?

Ugh, it didn’t occur to me to go to Corkboard option and change it from there. I think that’s how I did it several versions back. That deserves a whack on the side of the head :blush: . Thanks for the reminder!

I don’t know how it works on Windows, but in the Mac version it just uses the OS Font Picker, which always gives you the option for size, so there’s no way around it being part of the font selection even though ultimately in the case of stamps it makes no difference. I’d assumed Windows was essentially the same.

You may be right although I’d be quite surprised if it’s not possible to select which elements of the font selection screen appears. But even if that’s the case, seems odd to feature/mention the font size of the Status stamp in the options/cork board screen.

Not remotely important of course but it struck me as odd.

Same problem as others are reporting with Options, Appearance. Any changes made there do not show up in Scrivener after hitting Apply and OK, and they revert back to the default in the Appearance tab upon opening it again.

Perhaps this is why I have this black background on all my in-line footnotes, which totally obscures the text. I should be able to change the footnotes to a much lighter background in Options, Appearance, but any changes I try to make there will not take. Barbara (Beta 1.9, Windows Vista)

The footnote color bug seems to appear in other things as well (someone reported it in the highlight). You should be able to get a temporary fix by switching the footnote background color to something really dark–as I posted in reply to your original message about this, it seems that the color settings are working on a grayscale value with the values reversed, so the lighter the color chosen in the Appearance setting, the darker it is in the Editor. That worked for me, anyway.