Index Card help, add multiple lines? [BUG LOGGED]

This is not a bug, rather a “can this be done?” question on something that I think I might be missing how to do it (or would be a useful addition if I’m not just overlooking how to do it).

In working with the index cards, I encountered a situation where I want to use them to briefly block out a scene, which requires just a few points be made about that scene. Is there some way to insert several lines onto a card instead of one long line?

For example, rather than:

Can I have this?

Or am I just going to need to include each action in the scene on it’s own sub-category card?

I tried enter and that just exited to the selected card from edit mode, and a second click created a new card, so then I tried to hold the shift key as I hit enter and that had the same effect.

Help please? I really don’t want to have to have an unending line of text or to create 4 cards to block out one small part of a minor scene. Thank you.

Go into Edit -> Options and then go into your Navigation tab. Here you can change your Return Behavior to allow hard returns in your synopses instead of causing it to save the synopsis in question.

Hope this helps.

Thank you, Mightygitis, it did help, and I am able to now enter the information how I want it to look, however, I am still having a bit of a problem in that as soon as I no longer have the card in edit mode, the formatting all vanishes and it is one long line again.

Test card selected for entering text into the card:

Click on the cork backdrop and text all goes into a continuous line on the card:

Select test card and select the card in right column and it is formatted, but original card still lacks the formatted display:

And formatting is lost when cards no longer selected:

And no formatting on the card to right when I am in the writing area:

So, card can be formatted, but it only shows the formatting while in card editor mode.

Am I still just missing something very basic here? :confused:

Thank you again for the help. :smiley:

I get the same thing happening - with an extra bug!

I have gone into Edit-Options and changed the Behavior. Then I have redone my index cards, and all looks well. Then I have gone into something else (anything else), then come back to the corkboard, and not only have the cards reverted back to ‘everything on the same line’, I have found that, interspersed with what was originally a line, is a small outline of a square! so, instead of saying:

Rosie rebuilds Guardian
Verex tries to stop her
Timeline resets itself

The card now reads:

Rosie rebuilds Guardian [square] Verex tries to stop her [square] Timeline resets itself [square]

all on one line

I, too, get the little boxes instead of just spaces. Is everyone in this thread running the latest update as available in the sticky thread at the top of the Bug Hunt board?

Well, as per my signature, I am running Beta 1.2. Is there a ‘patch’ to this one? humbly

I think those of us running the latest are getting the tiny square symbol to indicate where a hard return is supposed to be. The original poster showed no squares, they might be running the original 1.0.

So at the moment, no fix for this one, I can’t find where it is logged, so hopefully it will get logged from here.

Actually, I think it might be Windows XP that is causing the boxes. I see that both of you are running XP, where I am on Windows 7 Home Premium.

I have Scrivener Beta 1.2 installed as per Lee’s update post, and I know it’s there because I no longer have that leap to my primary monitor when I go into full screen mode.

I tried every way I could think of to replicate boxes on my end, and can not get the boxes to show up.

I hit ENTER at the end of the line, tried SHIFT+ENTER, tried the enter on number pad, and shift with that enter. Tried entering text and picking something else out of the binder to tweak without deselecting the card I had wrote on. Tried every thing I could think might do it, and I can not get boxes to show up in place of the paragraph or line break on my version.

Yeah, the boxes appear on Vista too. I need to edit my signature, I’m actually bouncing back and forth between a netbook running XP and a full size laptop running Vista. Regardless this is a formatting glitch in regards to hard returns in synopses. I decided to do an experiment.

I opened the .txt belonging to one of my notecard synopses in regular old notepad and inserted returns there. Now I have THREE boxes in the place of each return instead of TWO.

I got a big kick out of that one.

This issue seems to still be present in Beta 1.3, at least using Windows XP, SP3.

Everything is fine when in edit mode, but as soon as you click off of the card, there are boxes and no line breaks.

I know that for some people this is probably a minor annoyance - for me it’s almost a dealbreaker as far as using the program, so I hope that it gets logged and addressed soon.

I will look into this and have added it to bug fix list.

Yeah, I get a little Greek looking “o” where my returns should be :slight_smile: