Index cards and text

When I copy text to an index card on the corkboard, it appears as one very, very, long row of text on the top blue line of the card instead of having “carriage returns” as does the copied text. Why?
How can I format the text on the cards?

Are you pasting it into the title field?

Actually, I am trying to type new info on the card; e.g. when I type a couple of words on one line and want to go to the next line to type additional “ideas”, I am unable to navigate to that next line.
Is their a special way to enter text on a notecard?

If editing the card in the inspector you can just press enter to get a new line. On the corkboard however, due to the nature of programming, enter saves the text and stops editing. (A second enter will create a new card.) Ctl-enter while editing will give you a new line.

If you’re interested in the reasons for this, there has been a fair bit of discussion on the boards as to why it is the way it is.

When you paste existing text into an index card you should be getting carriage returns. Even if you paste into the title area (but you’ll only see the first line). Here are two example cards, one using the red and blue theme, and the other using the blue and black theme:

So, “the top blue line” could be the title area if you have that theme set in your preferences. Also note that since these are plain text fields, to make a paragraph you need to insert two new lines.

As Janra suggests, if you are going to be doing a lot of typing in your cards, it is often easier to just use the Inspector (Cmd-Opt-I) as you can just press return as per normal.

Note you can have newlines in the title area. However this is not recommended as they will not show up in the interface (only one line gets shown) and this can lead to some very confusing results when you compile. There has been cases where people paste their chapter into the title field and the text area, and then get the chapter printed twice in compile because it is located in two places.

Thank you and Janra both