Inline footnote font size change

When I updated to the latest version of Scrivener, the font for new inline footnotes changed from tiny to normal size. Now I have a mix of both sizes throughout my document.

How can I make them all the same size?

They will respond to the Documents/Convert/Formatting to Default Text Style menu command, so unless you want them all to be different from the source text, that would be the easiest way to clean them up. If you do want them smaller, then there would be a way of doing that as well, but with a few more steps.

First you’d need to go into the Formatting general preference pane and set the footnote formatting to the way you prefer, then make sure the setting below that for inspector footnotes is also checked. Now you’re going to be temporarily converting the to inspector footnotes with Format/Convert/Inline Footnotes to Inspector Footnotes. Once they are in the sidebar, you can select all of them at once by clicking any one of them and pressing Cmd-A. With them all selected, right-click on any one of them and choose “Convert to Default Formatting”. Now that their formatting is updated, you can convert them all back to inline footnotes from the same sub-menu mentioned above.

You can do all of them at once by clicking on the draft folder in the Binder and forming a huge Scrivenings session out of it. That will then convert all of the footnotes to the sidebar, update their formatting, and then bring them back.

You might wish to make a backup of your project prior to doing that.

All right, all of that said: this is really only a concern for aesthetics. I myself wouldn’t bother with this at all. It’s just the sort of the thing that the compiler can clean up for you in one single spot. In the Footnotes/Comments compile option pane, there is a font override setting that will just always make sure your footnotes are formatted in a clean and uniform manner, no matter how messy things are in the work space.