Inline footnotes don't work

I’ve tried this over and over the past few weeks hoping it would fix itself but it hasn’t.

When I go to ‘inline footnote’ nothing happens. When I highlight the text and go to ‘inline footnote’ nothing happens. Or if I insert the cursor, go to ‘inline footnote’ and then start typing nothing happens.

It’s like that function is disabled or broken :confused:

I’d appreciate advice on how to fix this, as it’s going to cause a lot of problems when I eventually compile to Word!!

Sorry for a late response. Is this something you’re seeing in multiple projects or just one specifically? Since you mention it going on for a few weeks, I assume you’ve already tried restarting Scrivener?

I just checked and it’s only happening on one particular project as far as I can tell.

Yes, I restarted Scrivener several times and my computer too. It didn’t make any difference.

Hm. It’s happening in all the text documents in that project? Would you be willing to send a zipped copy of the project to AT literatureandlatte DOT com so we can take a look? Just use the File > Back Up > Back Up To… command with the “Backup as ZIP” option checked, then attach that to your email with a reference to this thread.

Other quick check, you said earlier “if I insert the cursor, go to ‘inline footnote’ and then start typing nothing happens.” Do you meant nothing happens, no text appears when you type? Or just that the text isn’t in the footnote bubble?

Thanks for your reply.

I mean that the text appears as normal, without the footnote bubble. It’s just like the footnote function has ceased to exist but everything else works fine.

Oddly enough, I can get the inline footnote to work on ONE of the text files (under Draft) and then only in some places, not throughout the whole text. I don’t have a clue why this is!

I’ll try to get the zipped file to you soon.

Thanks, I think the sample should help. Please also indicate in the email where the footnotes are working, for comparison.

I probably found the solution.

I am working with Scrivener now for about 10 days, on Mac and on Windows. I recognized this phenomenon after having imported a word.docx.

Anyway, here is the solution for the windows version (this problem does not exist in the Mac version):
(1) activate the text where that happens,
(2) go on the top of the window where you can choose the highlight colors (which is the background color)
(3) choose “remove Color”.

And that’s it.

It crossed my mind that the Scrivener handbook reads somewhere that Inline Footnotes are comparable to text that has been made bold or other comparable attributes. And I thought, there might be the footnote but nobody can see it :wink:

Aha! Thank you, AxMax! Filed as a bug. Tambourine, let us know if this fixes it for you as well.

Also I notice that sometimes the inline footnote toggle seems to stick, so it may appear “on” even when there is not a footnote, and clicking the button or using the shortcut key doesn’t activate it the first time. If you notice that the button has the blue highlight on it, try clicking it a couple times.

Thanks MM and AxMax! That did fix the problem! :smiley:

And I’ve also just noticed the ‘sticking’ problem while trying to un-footnote everything I had footnoted in an attempt to get it to work, so thanks for that tip too.