Inline footnotes to inspector footnotes

Sorry if this has been answered before. A couple of months ago I imported a lenghty word file (in Spanish) with a lot of footnotes. I’m using Windows XP. I was excited to see that with version 1.5.3 you had the option to convert inline footnotes (that I find to be distracting) to inspector footnotes. However, there are some issues:

(1) For some reason, conversion doesn’t really work. If i convert an inline foonote to a inspector one, the text of the footnote gets split, some of it remains inline, some goes to the inspector window, some will just dissappear. And it can not be undone with control+z, what is quite annoying.

(2) crtl + mayus + f doesn’t insert footnotes. But the shortcut will erase the content of a footnote if you use it when the cursor is on the word associated to an already existing footnote.

(3) for some reason i get some duplicated footnotes when i compile the text and the note number is right before a closing quotation mark. Obviously it has something to do with punctuation (I would like the footnote number to be before punctuation symbols, so I marked that option)

Thanks for the help!


There’s a bug with the conversion that’s causing it to not work properly in some cases when the inline note contains formatted text; we’re working to fix this for the next update. In the one example image, you’ve got some italics in the inline note which are currently causing the lossy conversion to the inspector note style.

If you get this, you can undo right after the conversion, when the focus is in the editor. You’ll need to hit undo a few times, however, as the bug is basically making the note convert in pieces (split with the formatting changes), so it may take three or so times using Ctrl-Z to undo all the pieces and get your full inline note back.

The Ctrl-Shift-F shortcut is a toggle for the formatting, so it in itself won’t “insert” a footnote, but it should turn on the formatting style so that if you use the shortcut and then continue typing, the newly typed text will be formatted as an inline footnote. It shouldn’t be removing the formatting from the entire footnote when you toggle it within an existing note; that’s a bug and is on our list for fixing. If you’re having trouble with shortcuts, try going into Tools > Options, and in the Keyboard tab, select “Scrivener” from the “Import” button drop-down menu. That will reset the shortcuts to the defaults and should clear up any crosswiring that may have occurred.

For the third issue, the duplicated footnotes, do you have steps to reproduce this? With the default options, I tried selecting the option to terminate the notes before punctuation and then in a new blank document typing some text, e.g.

"Example text with quotes".

I then applied an inspector note to the final word and quotation mark, excluding the punctuation, and compiled to RTF with the Original preset, then examined the results in Word 2010. The footnote marker appeared where it should, between the closing quote and the period. This appeared the same whether I used smart quotes or straight, but I used the default English style. It looked like that’s what you had in your document as well, but if you’ve selected a different style in the Options, please let me know as well so I can test with that. Being able to reliably reproduce the bug will help fix it faster. Thanks!

By the way, it may just be the compression and size of the images you posted, but the text in Scrivener’s editor looks a bit ragged, and that can be fixed by enabling ClearType in Windows.

Thanks for you reply, Jennifer.

I followed your steps and solved the problem with the shortcuts. And it looks so much better now with cleartype activated. Thank you.

As for reproducing the double footnote number issue: it is difficul to grasp how it works, but it looks like it has to do with the “number before punctuation” option.

  1. First thing is that I am not able to reproduce it in new text that I write. That’s good, but it does keep happening in the text imported with the previous version of Scrivener.

  2. In the text of the old-version-imported manuscript, it seems to have something to do with the combination of italics, quotation marks and dots. There where I have text inside quotation in italics and followed by a dot, the footnote number will get doubled. However, it also gets doubled in some text in italics between quotations without the dot following it, so I don’t fully get the mechanics.

  3. There are obviuos issues with the “number before punctuation” rule in inline footnotes, also when written new text in the updated version. Check the pdf I attach. It seems than inserting inspector footnotes is much more reliable right now.

Any insights on how to solve the old format-related foot number issues in the imported manuscript?

Thanks,
Manuel


test26.pdf (26.1 KB)

I would like to know whether there is any way to have footnotes of imported word-.rtf documents displayed by default with inspector footnotes rather than in-line footnotes. That way one could circumvent a faulty conversion from in-line to inspector footnotes of originally word-formatted footnotes (i.e. italic) within Scrivener.
Thanks,
Lesalla

For what it’s worth - I too would like to know if this is possible?

[EDIT:] And in answering myself… :smiley:

Just converted a lengthy, existing Word docx with many footnotes, into a RTF document - and then imported it in one go, into Scrivener. All my footnotes were directly converted into inspector footnotes, without me having to do anything.

As an aside, I made sure to strip my Word document of all comments/annotations/review-markings and any font/highlighting variances prior to the initial conversion - I’m not sure if this is necessary, but regardless - it worked perfectly [insert huge sigh of relief!]

Yes, at the moment footnotes and comments become inspector footnotes and comments when imported; you’d need to convert from there to inline if you wanted the other style. The bug with the conversion described up thread was also fixed in a previous version, so you shouldn’t have any loss switching between the types in 1.6.

Thanks MM!