Insert a custom image in the Custom Section Separator field in Compile

OK, I have searched high and low for this answer on the forum and I’m sure it’s here somewhere and I just can’t find it.

I know where to add a custom section separator, I just don’t know how to add the image that I want. If I have a custom image, say something I created in photoshop and exported as a jpg, can I add that in as a separator? I’ve tried copying and pasting it from Preview, Word and Photoshop (just in case there were strange metadata included with any of them), but the Custom Separator field will not let me paste. It’s greyed out.

Or, if there’s no way to add a symbol I created, how about a symbol that looks like a true section separator, not just an emoji? All I can find in Unicode are emoji-like pictures. And while we’re on that topic, how do I enter a Unicode? Do I surround it by <>? If I just type in the characters, it just exports that character string.

Thanks for your help!
Teresa

You add a custom image in the Custom Separator field, as you suspected, but I think you have to add a link to the image, rather than paste in the image itself.

Image links are covered at Section 15.7.5 of the Manual.

However, you ought to be able to copy ‘text’ images into the custom separator field from the Edit > Emoji and Symbols dialogue (Ctl-cmd-space).

[attachment=0]Screenshot 2021-03-16 at 18.36.41.png[/attachment]

HTH.

Brookter,
Thank you. I am going to go and read that section right now and see if it answers my question. I know how to enter a text image. But that’s not the type of image I would like to use.

Teresa

Sorry, I thought you were asking about Unicode characters, so I was just showing you the method you’d use to insert them as an alternative to custom images…

I hope you find what you need.

Bookter,
Thank you. I read through the 15.7.5 section and I was able to insert my image as long as I referenced it with the path where it is located on my computer, <$img:/Users/twiddowson/Desktop/glyph.jpg>

However, if I bring it into my binder and try to insert it into my compile that way: <$img:glyph> it doesn’t find it. It just types out the character string.

Any thoughts? No big deal, since I can just insert it from the file on my computer, I’m just curious because it seems like once I insert it into my binder in Scrivener, it should work just the same, just using the simpler path name.

Well, I am able to insert images into my compile from my computer (not from the Binder for some reason) but I cannot for the life of me figure out how to insert that image in between text sections.

How does Scrivener identify a text section so that it knows where to put the image when I put my <$img:> code in the Section Text, Separator Between Sections: box? I have tried everything that seems logical. I’ve read the manual. I’ve searched the web. I found something about how to do it on Scrivener 2’s compile, but I cant seem to replicate it on Scrivener 3. I know it’s a user problem but I cannot figure it out.

Help. :slight_smile:

Teresa

Theresa,

I’ve just tested this by importing an image called Die into the Research folder, then adding <$img:Die> to the Custom Separator field, making sure that:

  1. The section layouts are allocated to the appropriate section types. (Here the Section Type Section is allocated to the Section Type Text Selection
  2. I’ve selected Text Selection in the left hand of the Separator panel.
  3. Die is the Binder name of the image, not its filename.

[attachment=1]Screenshot 2021-03-16 at 20.41.49.png[/attachment]

This is what I see…

[attachment=0]Screenshot 2021-03-16 at 20.39.19.png[/attachment]

Does that help?

OK, our messages crossed… :smiley::.

The basic process is for Scrivener ‘knowing’ what you want it:

  1. You make sure that every compilable element in the Binder has a Section Type. By default this goes on hierarchy, as in V2, so folders have one section type (say Heading) and their subdocument have another (say Section), but unlike V2, you can assign as many section types as you need anywhere in the binder to reflect your requirements.

(NB: Section Type names are meaningless – you can call them what you want. The important thing is that you have a separate one for every ‘look’ you’ll want in the compiled document E.g. as long as Chapters and Scenes have different Section Types, it doesn’t matter what the name of the Section Type is. The defaults for many projects are “Heading”, “Section” etc. You can rename them if you want (Project > Project Settings > Section Types), but it’s not necessary.)

  1. In the compilation dialogue, you choose Assign Section Layouts, and there, for every Section Type, you scroll through the list of dummy layouts and choose the one that looks the way you want the final output for that section type to look.

Basically, in the Binder, you tell Scrivener “This document is an XX” (Section Type is Heading, Chapter, Appendix, etc), but “This document is a YY” (Section Type is Section, Scene, Prologue etc).

Then in Compilation, you say: “Make all XX look like this Section Layout” and “Make all YY look like that Section Layout” – in other words you assign Section Layouts to Section Types.

Say you’ve assigned all your scenes to Text Section — when you get to the separator dialogue, you’ll see the the Text Section line is in bold as Scrivener knows that this is one of the layouts you’ll be using. (As in the screen shot in my previous post). So, click on it and assign the custom separator as we discussed before.

This is the binder of my test project: you’ll see that both ‘Scenes’ have a Section Type of ‘Section’

[attachment=1]Screenshot 2021-03-16 at 20.56.12.png[/attachment]

And in this screenshot (from the Assign Section Layout dialogue in compilation), I’m assigning the Section type ‘Section’ to the Section Layout ‘Text Section’/

[attachment=0]Screenshot 2021-03-16 at 21.06.18.png[/attachment]

Because I’ve already set the custom separator for this Section Layout, the image is already visible in the dummy layout

Brookter,
Thank you for being so patient with me! I feel so silly now. I was simply typing in paragraphs in my text files (chapters), adding in extra spaces between paragraphs and expecting Scrivener to just find them. Now that I’ve changed them to ACTUAL “section” types in the Binder, the compile sees them as such.

However, I still cannot get the compile to find images in my Binder to use as a section separator. I can grab them from my computer just fine. I’ve got it in the Binder and I’m entering "<$img:glyph> in the Custom Separator field but it does not place it in my book after I compile.

I’m sure it’s a user error. Any thoughts?

I’m glad it’s helping! The idea that you should break your project into ‘chunks’ in the binder (e.g scenes rather than chapters etc) is one which unlocks a lot of Scrivener’s most helpful features, as you can then manipulate and analyse them more easily.

The only reason that I can think of that the setting hasn’t taken is that you haven’t linked up the right section layout to the right section type.

Could you try these detailed steps, please, based on your screenshots. That way, we’re both using the same terms at each stage.

1. Confirm that you have a different Section Type in the Binder for each of the three levels DAY, CHAPTER and SECTION. (It doesn’t matter what the names of the Section Types are, but the binder must have at least 3 different Section Types for the structure you show in your screenshot.). Click on Manuscript, then toggle cmd-3 to show the outline. If the Section Type column is not showing, then click on View > Outliner Options > Section Type. Something like this:

[attachment=1]Screenshot 2021-03-17 at 08.08.38.png[/attachment]

  1. In the first compilation dialogue, click on your format (Ebook Copy) and then on Assign Section Layouts. If you look at the right hand panel you can check the hierarchy of your project and their Section Types. You can change them here if you want.

[attachment=2]Screenshot 2021-03-17 at 08.10.39.png[/attachment]

  1. In the dialogue which comes up, you’ll see that all your Section Types (here, Heading, Sub-Heading and Section) appear on the left. You have to click on each of these in turn and select the dummy layout on the right which best matches your requirements for that Type.

Here I’ve chosen the layout Section Text for the type Section. (NB. I didn’t choose New Section, which has a Section Break before it because we want to do this manually, and I’m not sure exactly how New Section is set up.)

[attachment=0]Screenshot 2021-03-17 at 08.16.23.png[/attachment]

We should now have set the basic project up. The Days, Chapters and Scenes will be separated by whatever section break is there by default (a blank line for scenes in an Ebook, I think.)

[You can only have three images per forum post so this will continue in the next post]

[Contd]

So, we have produced a basic Ebook, with blank lines between the scenes (I made a couple of choices about the layouts for Heading and Sub-heading for the Day and Chapter, but that’s irrelevant for our purpose — you’ll make you own.)

[attachment=2]Screenshot 2021-03-17 at 08.36.26.png[/attachment]

Now we’re happy with the general layout, we add the custom separator from the standard 'Edit Format dialogue you’ve used before. You can also get to it by clicking on the little pencil in the Assign Section Layouts > Section Text dummy layout (you have to hover the mouse over the layout to see it).

Go to Separators and you’ll see that the three Section Layouts you’ve used are now in bold (I think this happens after you’ve compiled once.)

Click on ‘Section Text’, choose Custom from ‘Separator between sections’ and add <$img:glyph> as in the screen shot.
[attachment=0]Screenshot 2021-03-17 at 08.51.33.png[/attachment]

Click on the Test button and you should get this:

[attachment=1]Screenshot 2021-03-17 at 08.52.18.png[/attachment]

If it works, press the Save button and you’re done (except for choosing more appropriate layouts for the Day and Chapters than the ones I guessed at, of course…) and can carry on with the full compilation.

BTW, if you go back to the first compilation dialogue, and scroll down the list of assigned layouts, you’ll see that the glyph is now part of the dummy text for the Section Text layout.

It sounds complicated, but once you get the hang of the Section Type > Section Layouts > Test the Defaults > Customise Individual Layouts process, it’s actually quite logical.

Anyway, I hope this helps!

Brookter,
I am able to get everything to work exactly as I like it. Thank you for your help.

The ONLY problem I am having now is getting the compile to use the text separator image if I put it in my Binder. If I don’t try to get the Compiler to grab it from my Binder and instead just pull it from my computer directory, it works fine.

If I type in the string: <$img:/Users/twiddowson/Desktop/glyph.jpg;w=150>
it works like a dream.

But if I type in <$img:glyph>
it does not see it and just gives me a blank line.

It is not critical since I can get it to work, but I am just curious why it doesn’t work if I put it in the Binder.

I’ve attached a few screenshots to show the file in my Mac directory, in my Binder, and how I am entering it in the Custom Separator field.

Is the glyph inside a text document in the research folder? If it is, that will cause a problem.

The image should just be dragged and dropped into the research folder as it is … not embedded inside a text file.

Sample project attached.

Merx.

[attachment=0]Test.zip[/attachment]

That’s a good point, @Merx.

The ‘glyph’ png I use in those screenshots was dragged into the Binder from the finder: it wasn’t inside a text document.

Thanks.

Didn’t mean to cut in. And I may well be wrong. Was just suggesting something to check, in case you weren’t able to reply for a while. Excellent guide, brookter. Bookmarked and applauded.

Merx

I think you’re probably right about the image needing to be its own - it hadn’t occurred to me that this could be the problem, so I’m glad you pointed it out!

Thanks!

Thanks Merx. I will check that and let you know.

That was it! You guys are geniuses. For some reason the file was not an image file in Scrivener. Somehow I imported it in incorrectly.

THANK YOU! THANK YOU, for all your help. My ebook looks so professional now!

Wishing you every possible success with the book.

Merx

Excellent — good luck with the book!