Insert time in 24 hour clock

My date/time settings are correct in my Macbook Pro and show in 24 hour clock on the computer. However, when I insert the date/time in my notes, I only see AM/PM. Am I missing somewhere to change this, or is it a bug fix or something to add to the wish list?

Thanks…Tony

Hi,

It uses the “Short” style set under System Preferences / Language & Text / Formats (choose “Customize…” next to “Times”). The “Short” style on my machine is set to use a 24hr clock, so that’s how it appears when I use Insert > Current Date and Time.

Hope that helps.

All the best,
Keith

Thank you, Keith. That works.

A note for anyone else trying to follow this…

Under the “short” format in the Mac settings, delete the AM/PM indicator. Also, right click on the hour and change it to a 24 hour setting.

All is good now.

Tony