Insertion point bug

When writing or editing insertion point sometimes “grows big”, hiding previous letter if this letter is narrow and semi-hiding, if letter is wide. For example:


Here is string “This part of” and the input focus is set right after f letter. I can’t figure out the pattern, sometimes the problem arises and after a while it disappears. Windows 7, Lenovo laptop with Intel graphics card.

There is an option to use a fat cursor, in the Editor option tab, but that shouldn’t be spontaneously turning on and off—and besides it should be using black to draw it and not the background colour. I don’t think that is what we are seeing here in this screenshot. It looks and acts more like an old school cursor in DOS.

What font are you using, and are you writing in a language that uses 2-byte characters?

It’s Lucida Sans and indeed the story contains Cyrillic text.

Someone else reported this and actually I was able to replicate it repeatedly this morning when working in a Scrivenings session, so I’ve popped that off to Lee–there are a few bugs right now that Lee’s working on fixing that are related to Scrivenings, so I think it may be tied up with one of those. Outside of that I haven’t been able to reproduce this–are you seeing it when just a single document is loaded in the editor?

Yep, on single documents.

I see it when looking at a single folder’s text in Editor, with Inspector window open too. See it sometimes (20% ?) when I initially switch from one folder to a another folder. Doesn’t seem to matter which folders. If I switch to original and back again - problem has gone away. Haven’t noticed anything consistent, other than if I turn off inspector (click the ‘i’) always is back to normal view-able cursor. And when turn inspector back on - still see the normal cursor.