Inspector panel gets a bit corrupted (after using bookmarks?)!

Sometimes, the Inspector panel will miss the 5 icons in top. The only way I have found to get them back is closing Scrivener AND rebooting Mac! There must be an easier way?

First picture is when it is OK

Skærmbillede 2022-12-19 kl. 17.08.34

In the second picture the icons are missing! A well as my Custom Metadata.
Skærmbillede 2022-12-19 kl. 17.06.51

Since this error has only begun after I use bookmarks, I would like to get some help on how to apply those bookmarks ‘correct’.

I want to use bookmark linking to other Scrivener Projects on my disk. Should I add the bookmarks to the top folder “Draft” or better to a folder one level down???
In some instances the bookmark dissappears when opening Project again, Sometimes the Inspector icons disappears too. :roll_eyes:

Skærmbillede 2022-12-19 kl. 17.17.49

I run macOS 13.1 on a Macmini M1 and uses Scrivener 3.2.3

I am not on Mac, but I would say that a workaround that could probably work would be to link to those other projects in a document, in the editor, and bookmark that document rather than the projects themselves, in the Project Bookmarks.

You are not on the metadata panel in this screenshot.

Correct, and I want that back, but the screenshot is covering the same pixel area :slight_smile:

Have you tried toggling the inspector invisible then visible ?

image

Or navigating back to the metadata panel using the menu navigation ?

(That’d already be better if it works than having to reboot…)

I just tried a third version:
removing the bookmarks from “Draft” and restarting scrivener, then all is fine again.
For me bookmarks are a simpler tool, rather than using finder to locate the specific projects.

But since bookmarks are new to me, I hope to get better in this respect too.
I looked into the big manual but found nothing describing the specific error I encounter

:sunglasses:

Have you tried this ?

Else no, I doubt you’ll find anything telling you not to do what you did in the manual.
This is clearly a bug.

No, because that is not practical for me, the way I work on these items.

Basically I use the bookmark to get me quick to other projects which I then use as lookup/referenses.
before I knew of bookmarks I simply clicked a lot more before I got the projects I needed to open.

This is by no means slower or more complicated :

image

You can even drop new links right in the bookmark’s panel’s bottom section, or open those projects from it without disturbing the editor’s content.
It is the same as what you were doing, really.
The only difference is that you’d bookmark an internal document, instead of bookmarking every single linked projects.
As a matter of fact, it is even likely better than the way you were initially doing it. And it might just fix your issue…

Ok I will try this out, I did not fully contemplate that the document you mention could reside “anywhere” in my project as long as I had a bookmark linking to it

I’d put it somewhere in the Research folder, if it was me doing it.
You won’t really need the document in itself. As long as it is bookmarked and exists in the project, all you’ll need is the bookmark panel.

I did that … and it worked… until the inspector got stuck into the version you get when you select the top folder “Draft”.
Maybe its a bug, maybe there is something that can be coded better?
I say as Arnold: “I’ll be back”

I think LL’s staff would in this case tell you something in the line of “ditch the visual file from the software”.
Which I have no idea how to do.
So don’t act upon what I just said, I’ll bring it to their attention.
@AmberV @kewms

1 Like

I’ve been playing about a bit on my M1 MBA, running MacOS 13.1 and Scriv 3.2.3 and don’t have the same problem, so I guess you’ve got a slight corruption somewhere. A question and two suggestions:

  1. What theme are you using? I wonder if there might be anything there. I always use default-light, but I’ve just tried with “A midsummer night” and “Solarized dark” with no adverse effects.

  2. My next move would be, with Scriv closed, to move the prefs file out onto the desktop and then open Scriv to create a new prefs file. If that cures it, you’ll need to reset all your preferences; if it doesn’t cure it, trash the new file and move the old one back to re-instate it.

  3. Third move would be to hold down the option key and choose File → Close Project and Clear Interface Settings.

You could 2 before 3 if you prefer.

:slight_smile:

Mark

Hmm… I checked om “Theme”… got a checkbox if I wantet to change both dark and light version, picked just the dark, since I work in that mode, then it crashed:

:roll_eyes:

and now it is REBUILDING index :roll_eyes: :roll_eyes: :roll_eyes:

After rebuild finished …
well it is a bug, so how do I report that???

No metadata no nothing

1 Like

Well I reported the bug… and then got the auto- response that support is off to santa claus until next year.
Anyway I have made a short KM macro that will open the needed projects, simply by using a 3 key hotkey-combo.

Now… this calls for a Carlsberg :beer:

1 Like

On second thought, this tuesday morning, I will stay with this option you suggest.
I placed the small document in Research and made a project bookmark to that. Opening the projects from this place (using the second icon, not the big one on top) will not wake up the bug. After closing the Project and reopening it the Inspector panel is as it should be.

… so bug or not, this is a more natural way for my workflow. Thanks for your useful input. :+1:

:coffee: :coffee: :coffee:

Okay, in my testing it looks like the toolbars have something to do with it. We should have enough to reproduce the issue at this point though, thanks for the report!

I’m having this problem too. Running Scrivener 3.2.3 on iMac under Mojave (OS 10.14.6). Have to close all open projects, then close Scrivener, and reboot to get the icons back. None of my bookmarks are to other Scrivener projects, but most are external links. I do notice that my smaller projects don’t seem to have this problem; only the larger ones.