Inspector panel gets a bit corrupted (after using bookmarks?)!

Ooops. What I just wrote isn’t quite true. Closing and restarting brought the icons back in some of the projects, but not all of them.

Last note, I promise. I was browsing other bug reports and found a thread called “Inspector toolbar stuck in the Inspector column,” about inspector icons moving to other parts of the window. The fix recommended was:

  1. Close the project
  2. Quit Scrivener
  3. Find the project in Finder
  4. Duplicate the project in Finder (to have a backup)
  5. Right click the project in Finder and choose ‘Show Package Contents’
  6. Open the ‘Settings’ folder
  7. Delete ‘ui.plist’
  8. Reopen the project (‘ui.plist’ will recreated) to see if the problem has been resolved 9. Any problems, revert to the duplicate of the project

This worked for me. Still annoying, but less annoying than having to re-boot the Mac, and much less annoying than finding the reboot still didn’t fix the problem.

1 Like

Something I noticed, when I was writing this up, is that I could really only get it to trigger if I left the inspector open when closing the project. If the project window loads with it closed, then it was fine throughout the session. So that would be a much less disruptive thing to do than nuking all of your project settings every time you encounter it.

But that may be an OS version-specific quirk, I don’t know. I was primarily only testing in macOS 11, and stuff like this can sometimes change from one Apple update to the next.

I’m not sure that that works consistently. Even if it does, you still have to repair the headers first. I’ve looked closely, and I’m now convinced that this is, at least on my machine, a variant of the “Inspector toolbar stuck in the Inspector Column.” I looked very closely at the blank space in the Inspector header, where the icons should be, and I can see a hint of a grey line (see circled part of attached screen shot). If I click the mouse elsewhere along that line, I can move from the Metadata pane to Bookmarks to Synopsis. So the icons are there, just not visible. And deleting the ui.plist fixes that problem every time.

Screen Shot 2023-02-07.jpg

I give up. I upload my screen shot, but when I try to send, I get the message “An error occurred: Sorry, you can’t embed media items in a post.” What am I doing wrong?

Nothing.
The forum has a spam protection.
It takes a few days before you can post images.

I don’t recall if letting it corrupt and then hiding the inspector and reloading worked. To clarify, I meant closing the inspector before the bug is ever triggered, as part of how one closes a project, avoids the problem in my testing. Once it is triggered—who knows. There are many ways in which bugs manifest, the most important part though is how they trigger—and that can seemingly be narrowed down to the inspector being open on project load, when inspecting a document that has a type of bookmark added to it.

At any rate, if you haven’t done so already, I’d suggest taking a look at the Layout feature, documented in §12.3, Saved Layouts, so that you can consider changing how your project looks without fear of losing settings every other day.

I’m still trying to post my screen shot. How much longer will it take for me to get permission. (I’m a long time user, and respondent, on these forums, but unfortunately haven’t posted in a long time and had to give up my prior email.)
This problem is a legitimate bug. Has it been reported as such?

I’ve updated your trust level, so you should be able to post screenshots now.

Yes, the bug has been reported. Everything from this post of Ioa’s on is discussion of potential workarounds and ways to avoid triggering it: Inspector panel gets a bit corrupted (after using bookmarks?)! - #24 by AmberV

As there seems to be some confusion: your description of the problem before was good enough, I know what you are talking about without a screenshot. It is discussed in the very thread you are responding to, where it is stated that this bug has been documented and filed.

So we do not at this time need any further data or screenshots. Thanks though!

OK, thank you all. I’m posting my screen shot anyhow, even if it is redundant, if only because I have kindly been granted a higher trust level ( which I won’t abuse). I note that it is possible to work with the “blind icons,” no fixes or workarounds necessary, but definitely a sub-optimal solution.

I’m glad that the bug report has been filed. I’ll note for the record that between this thread and the other thread that I mentioned, I seem to be working on the oldest OS. Others have reported the same problem on newer releases. So if the bug is the result of an OS update, then maybe it started with, or before, Mojave.

Meanwhile, I will keep trying AmberV’s suggestions to see if I can find something painless that will work for me. Thank you.

Yup! That’s what the problem looks like to me in most cases. I’ve seen other variations as well, some worse with text elements overlapping others, but they all seem to stem from the same cause of having bookmarks of a certain fashion in an inspector that is visible when the project loads. The other necessary trigger seems to be the use of toolbars. I couldn’t see this bug at all when I first tried to reproduce it, because I don’t use toolbars! So that’s another workaround if you don’t really use those.

Others have reported the same problem on newer releases. So if the bug is the result of an OS update, then maybe it started with, or before, Mojave.

Yeah, I’ve managed to reproduce it in macOS 10.14 and up. Presumably it happens everywhere, though how it looks does seem to change, probably based on different UI element sizes as older systems are a lot more compact and tidy whereas newer ones have large amounts of whitespace and padding everywhere.