Installation Problem : "Wrong architecture 'i386' "

hi there,

i tried install scrivener via ‘gdebi scrivener-’ on both ubuntu 11.04 (running inside parallels desktop on a mac with an intel core i7 x86 chip) and on raspbian (a raspberry pi with an ARM chip running raspberry’s custom debian flavor)

both systems give me the same error:

This package is uninstallable
Wrong architecture ‘i386’

is there any way i (a linux semi-newbie) can make this work?

It will NOT work on an ARM chip-based computer.

In Ubuntu, you have to force it to install on a 64-bit system with the following command:
sudo dpkg -i --force-architecture ./scrivener-*.deb
Hopefully it won’t give you any other errors, you may have to do one or two more steps. Try that first.

Is it possible that you are running a 64 bit system and therefore it objects to the 32 bit code? If so you might try following various tips in this thread:

Hope that helps.
All the best,

PS That is regarding your mac. As already mentioned it won’t work on an ARM based Raspberry Pi.