Intrusive Safari on iOS

Safari is not my default browser on any of my devices—on MacOS (and Windows running under VirtualBox) it is Opera, on iOS it is DuckDuckGo—and yet every site I visit on the iMac running 10.15.7 immediately is mirrored in a new tab in b****y Safari on my iPad. It irritates the hell out of me! :smiling_imp:

Do any of you iOS experts and users here know how to stop this happening? I’d really love to know how to do it.




On the iOS device


[Your name]



Toggle off the rocker switch

Or if you wish to share tabs on iOS devices but keep your Mac out of it––at the Mac - System Preferences > Apple ID > iCloud > untick Safari.

(That’s for Catalina and newer, according to Apple; Mojave and earlier it’s at System Preferences > iCloud >Safari.)

Thanks for that suggestion … actually, Safari is already turned off there!

OK, thanks, I’m trying that. But I don’t use Safari, yet it’s been hijacking the links in Opera, which is Chromium based … not the same engine!

I’ll tell you how I get on.


Very odd. Inexplicable on many levels.

I would try signing out of iCloud on the iOS device and then cold booting and checking if the issue had gone. I’d then sign into iCloud again and see if the issue returned (having made sure Safari syncing hadn’t switched itself back on automatically when signing back into iCloud).

If the problem recurred, I’d get in contact with Apple tech support as the issue clearly shouldn’t be happening.

Be interested to know the root cause of the problem.

Good luck. All the best for 2021.


In spite of having done as you both suggested, it’s still happening!

I could try signing out of iCloud etc. and trying again … as for Apple tech support, hmm …

I’ll put it on the back burner for the moment; there are more important things in life!

May 2021 prove a better year for all of us.