Invalid project error with 2.8 (and also iOS)

OK so I’ve upgraded my desktop to 2.8 and bought the iOS version. When I try to open ANY of my Scrivener files, I get this error on my desktop. This is before I tried to sync anything with Dropbox.

When I move one of these files to Dropbox, and try to open in iOS, I get this error message in iOS:

Invalid project.
The project cannot be opened because it does not contain a valid binder structure file.
OK

Any ideas?? :question:

(PS Sorry I posted this originally in another thread in the iOS forum, but think it fits better here.)

Have you followed the instructions in the dialog and ctrl-clicked on the file in Finder, etc?

When I ctrl-click on it in Finder, there’s no option to view the contents. When I option-click, there’s not there either.

If I change the extension to ZIP, then I can unpack and see the contents, and I see there’s a “binder.autosave” and “binder.backup” file under Files, but that’s it. I tried changing the binder.backup to binder.scriv, rezipping, re-changing the extension, but that didn’t work either.

And you are ctrl+Clicking on the *.scriv “file”?

You’re not in Finder.
At the bottom you have “Reveal in Finder”.
So, where are you looking at the files?

I am in Finder. When I click “Reveal in Finder” the dialog just goes away and shows me the Finder box I’m looking in.

The dialog box in where?

Open Finder, navigate to the correct folder and Ctrl+click the scriv package. If you refuse to follow instructions it’s impossible to help you.

Friend, I don’t think you understand. Here’s the steps I’m taking:

  1. Finder: File/New Finder Window
  2. Click on Documents
  3. Control-click on the scriv file
  4. The image you see above
  5. If I click on “Reveal in Finder” it shows me the same window I’m in.

If you know Mac, you know the screenshot above is clearly in Finder. If you see I’m doing something wrong, feel free to tell me where.

Here’s a clearer image that proves I’m in Finder if that helps:

No, the screen shot is not from Finder, because Finder never has a Reveal in Finder option. It looks as some kind of Open file dialog, from some other app. So where did you start, to come to that first dialog in your screen shot? Inside which app? It’s definitely not Finder.

If you are unsure where you are, click Reveal in Finder! :slight_smile:

Then you will undoubtedly end up inside Finder and can ctrl-click the same file.

I wouldn’t go so far as to say that. You can add services via scripts that are titled whatever the author of the script decided to title them… including “Reveal in Finder”. The proof that JD is in the finder is at the top of the last screenshot; the menu bar doesn’t lie.

I think this is key; you’ve managed to produce a zip-compressed archive with a .scriv extension. Choose “Get Info” from the Finder’s pop-up menu (as seen in your screenshot), and it will hopefully identify it correctly. What you need to do is to extract the contents of the .zip version of the project. Don’t re-zip it after doing anything. No version of Scrivener can work with a zip-compressed project, even if if that compressed project lacks a .zip extension.

For your viewing pleasure: youtu.be/UDA3g8U_Eko

So when I choose Get Info, it says it’s a Scrivener file. If I change it to ZIP extension, and choose Get Info, it still says it’s Scrivener but still can’t open it. If I unarchive it, I can see all the files, but of course, it seems unusable then…

I wonder if something happened in my backup that did something to these. It’s just weird because ALL my Scrivener files are behaving this way since I moved to 2.8.

(Note that I don’t keep my documents under “Documents” which is why you see nothing but the one file there in the video above. I moved it there for ease of seeing when recording the video.)

You must have done something more than just upgrade to 2.8. If you hade 2.7 before and the only thing you’ve done is to upgrade to 2.8 there is no way all your Scrivener projects would have been corrupted simultaneously by the upgrade of Scrivener.

So think back. What else have you done on your desktop? If you don’t get the Show Package Content option when you ctrl-click, it’s not a Package. Have you been moving files in way that the packages were destroyed?

No “Hey you were right–that WAS Finder?!” :laughing: Just kidding. I appreciate you sticking with me.

OK, I think you’re correct about this. Something happened when I moved my files. I moved them to the desktop in preparation to put them in Dropbox to use with iOS Scrivener and something happened on the trip.

So, I’ve gone back and pulled backups. When I move those to my desktop, I was able to get them to open in Scrivener 2.8 and convert over.

I see that moving them directly into Dropbox directly isn’t the answer; Dropbox is adding a ZIP extension to them too.

I appreciate the help, guys. I’ll check for the steps to this next solution, which I’m sure is in the help files. Thanks again!

Ah… you made that mistake that others did? You moved the files from their location in Finder onto the Dropbox app?

Yes. I don’t know why these cloud services change the file and don’t see it like we do on the desktop. That level of coding is beyond me…

If you move a complete package onto the app it interprets it as a wish from you to zip it, that’s all. If you only wanted to move the files, the app expects you to use Finder’s drag and drop within Finder, and not bother the Dropbox app.

That makes sense. Appreciated.