Inverted preview image in High Sierra

Preview Image is Inverted In High Sierra
Screenshot :

Both Finder preview and quick look
Screenshot :

All my Scapple files are the same.

Thanks, that looks to be a universal issue with the beta version of macOS. We’ll look into it!

It seems to be a drawing bug in High Sierra. I’ve checked Scapple’s Quick Look preview generator and the code all seems fine - as recommended by Apple for generators. But something in High Sierra is causing it to come out upside down. And of course, flipping it the right way around on High Sierra causes the preview to appear upside-down in earlier OSes. I have it on my list for further investigation - if it’s not something fixed on Apple’s end before High Sierra’s release, then I’ll dig deeper and possibly just flip things when it’s viewed on High Sierra.

It is is still happening now that High Sierra has been released.

Just come across this, which is very annoying. Has anyone come up with a solution? I habitually use “Quick look” in finder
I will be very interested to know how to remedy this bug

Have you applied the Scapple 1.3 update yet? Since Apple never fixed this, that update includes the patch for the problem KB referred to above. If you bought from Apple, the update will be available soon.

I see the inverted images after importing the files into Scrivener 3 (using Scapple 1.3.1)

I’d try a reboot cycle into safe mode to flush system caches. I wouldn’t think Apple would cache an application’s Quick Look mechanism, but Apple seems to cache more and more with every update, so who knows.

UPDATE: if you have this problem of the old Quick Look engine not updating with 1.3+, then read this post for a procedure that should cause the system to fully discard the old engine and install the new one.

Either way, on a fresh system with Scapple 1.3+ you shouldn’t get this problem. Scrivener has nothing to do with it by the way—it will be inverted in Finder, DEVONthink and anything else that makes use of Quick Look.

Hi everyone. Has anyone found that Scapple files (Scapple 1.3.1 (61) when imported into Scrivener3, either via the file menu or by dragging, results in inverted text? Very strange. I also created a test Scapple file and the same happened. Would appreciate some thoughts.

[By the way, I joined using Windows but now am exclusively mac]

Have you upgraded Scapple from 1.2 to 1.3? Experienced the problem myself with 1.2, and reported it. Apparently something happened when Mac OS went from Sierra to High Sierra. When I upgraded Scapple to 1.3, the problem disappeared and it now works for me as intended.

Yes, I see the same thing. Scapple 1.3.1, Scrivener 3

Moderator Note: merged with existing thread in bug hunt board.

I tried restarting in safe mode and the issue remains. This problem effectively renders the integration of Scapple and Scrivener (a major selling point) useless. I am disappointed, and frankly, a little surprised that this gets such short shrift from L&L.

Is it perhaps an older file? Here’s what I tried:

  1. Created a new blank project.
  2. Created a new Scapple board and added two notes in vertical orientation.
  3. Saved the board to the disk.
  4. Dragged the .scap file into the test project.

Result: right side up.

Do you get a different result with that precise checklist?

High Sierra 10.13.3 / Scrivener 3.0.2 (1506) / Scapple 1.3.1 (61)

Followed the above steps, same results as before

Strange! I still have no luck seeing anything like this, even after testing with precisely the same versions of everything you are using. Do you see this happen if you create a test Mac account and throw a sample Scapple into the tutorial project or something, on this same computer?

Same issue.

BTW–I notice that ONLY Scapple files appear inverted in Quick Look

Have you tried doing a total wipe of Scapple and reinstalling it? Here’s how I’d do it:

  1. Delete all copies of Scapple from /Applications.
  2. Empty the Trash.
  3. Reboot with the Shift key held down until you see the Apple logo.
  4. Once you log in to safe boot mode, reboot again.
  5. Open your test Scrivener project with the .scap file and refresh it using the button on the right of the footer bar. You should see code. Scapple doesn’t exist now, so there is nothing to turn this code into a picture. If you don’t see code—stop the test. There is no point in continuing if the old Quick Look engine fails to uninstall. I have no idea why it wouldn’t be or how to force it to though.
  6. Close the project.
  7. Reinstall Scapple 1.3.
  8. Run Scapple once.
  9. In Finder, select a .scap file and hit the Spacebar to Quick Look. This will get the 1.3.1 engine installed and running.
  10. Load your test project and again refresh the .scap file.

Woo Hoo! This worked. Thank you!

Excellent! I’ve updated my earlier post that only suggested the safe boot to refer to this checklist instead, for anyone else that has a stuck display engine.