iOS 10 on iPad = problem on iPhone?

I just updated to iOS 10 on my iPad and now scrivener will not open at all on my iOS 9 iPhone. Just a flash on the screen and that’s it. It works fine on the iPad! I did do a sync from the iPad to dropbox just before it happened . Could that be part of it? Tried rebooting the iPhone – no luck.

I’m not following the initial question, did you mean to say that after updating your iPad to iOS 10, the app doesn’t load on your iPad? I’m lost as to how that would have anything to do with your iPhone.

That aside, do you use Dropbox? If so, I’d go into Scrivener’s Settings.app pane, under Reset, and reset the Dropbox sync cache. Sometimes its cache can get jammed and since the first thing Scrivener does is check for sync status, it crashes the moment you load.

As strange as it was, my initial post was correct. I updated the ipad to iOS 10, loaded it fine, then Scrivener on my iphone only shows the big scrivener S for a second, then vanishes. I went to Settings->Scrivener and selected the Dropbox reset, but no change. So, being clever, I went in through itunes to file sharing and deleted the Dropbox folder on my phone: no change. I guess reinstall the app, eh?

To get the basics out of the way, I’d also fully reboot the iPhone as well. You could also put it in Airplane mode so that it cannot access Dropbox at all as a check to see if its the problem. If it still halts with Airplane mode on then the rest of this post might not be worth trying and a reinstall is what I’d recommend.

The only thing I can think of that might “communicate” a problem from one device to another are settings files in the Dropbox folder (it still feels like a coincidence to me, but this is where it would happen). In theory the software should not be changing those, but it’s worth a check:

  1. On your Mac, move everything in the Dropbox folder elsewhere.
  2. Make sure Dropbox fully gets the message and removes the content from its server.
  3. Now try with the iPhone. I wouldn’t actually sync (although it sounds like at this point you don’t have any local content stored in the Dropbox section on the iPhone, having removed that folder with iTunes), just see if you can get in at all.

If that works then I would try moving things back into the folder from the Mac incrementally, testing in between each batch of added content. If it breaks, you know it’s something you just added.

I tried everything and nothing worked, so reinstalled and it is fine now. Thank you!