iOS Compile "dumb punctuation" option doesn't convert dashes correctly

I usually compile from my Mac but today I compiled a draft on iOS, using the Manuscript (Courier) format. I just confirmed that this compile format has the command “Transformations: - Dumb Punctuation” in it.

I have probably more em-dashes than are good for me in my manuscript. On inspecting my output I discovered that none of them had been replaced with “dumb punctuation”, i.e. two or three hyphens. Instead, each was replaced with a single hyphen. I tested with en-dashes and they weren’t replaced with correct dumb equivalents, either. Curly quotes and ellipses were dumbed-down correctly.

bump.

Excuse me, but is this a bug? Is there a workaround?

Hi, folks. I still want to know if this is a bug, and whether there’s a workaround. It’s becoming more important now that I gasp actually have a real, live, professional editor… :slight_smile:

Sorry! I didn’t notice this report before. I’ve done a quick check and it looks like the “Dumb Punctuation” transformation option currently is dropping both dash lengths to ordinary single hyphens. I’ll make sure Keith is made aware.

Workaround: only thing I can think of is a hard conversion with search and replace on the original source—easier done on Mac than iOS, for lack of a global cross-file search and replace on the latter. I’d normally say the other workaround would be compiling on the Mac, but I note it is also overlooking en-dashes at the moment, though it handles em-dashes to two (or three, when using a Markdown variant) hyphens.

Thank you, Ioa.

This is fixed for the next update.

Thanks!!!

This is now working in v. 1.2!