iOS keyboard clicks

Can someone please share the secret for turning off keyboard clicks on an iPad IOS 9?

I’ve got the volume muted and have disabled keyboard clicks from app settings, but the keyboard on Scrivener and Safari and email is still clicking!

What am I missing please?

Thanks,
Jim

Have you tried restarting your device yet? It sounds like the preference isn’t doing anything for you, which speaks to some deeper problem than what can be solved with settings. As for myself, I have no issues at all toggling the keyboard click on and off and this setting works for everything.

If you’ve shut them off in sound preferences and you get no joy from a restart, you can try a forced restart. This sometimes corrects a wide range of issues.

support.apple.com/en-us/HT201559

After I posted last night, the iPad went to sleep (as did I!).

Now it is working for me as Amber mentions above: toggling keyboard click on and off works for everything.

Thanks for your replies!