iPad -Scrivener-Dropbox ’hell’

Like many others in other threads I’m unable to access a Scrivener(3) project on my iPad that was created on my Mac. I’ve done everything required re. Sync and much patience but all I get is the annoying error (image attached). Scrivener on my MacBook opens fine and mirrors the desktop but IOS is terrible and frustrating. I have 9 projects on the go in Scrivener and the one I cannot access on IOS is the most important. All other projects open just fine On Mac and MacBook. I have even left everything alone overnight, restarted everything, made sure Dropbox is finished syncing then tried to open the project on iPad but same error appears. Is there a solution please? Can I check on this ‘binder’ file it seems incapacitated without? Many thanks

Sync troubleshooting guide can be found here: scrivener.tenderapp.com/help/kb … os-syncing

Are you able to sync in the opposite direction? That is, if you create a project on the iPad, does it successfully sync to the desktop?


Have you tried the obvious? On your Mac: Save it elswhere under a new name (Save as… in another folder). Move the current version out of your sync folder. Move the renamed version into the sync folder. Close Mac Scrivener, wait for the Dropbox app to show that everything is synced. Start your iPad Scrivener, sync.
Is it still saying the same thing?

I can’t quite tell from the initial description if you have other Scriv projects that you are dropboxing and which open fine on you iPad. Knowing the andwer to this would be some help in troubleshooting.


Hi. I’ve gotten this if I move the project to another directory (if I create a project on the iPad, often times I want to move it to a more structured location, nested within the top directory that Scrivener originally saves it). Once I sync, I see two listings for the same project in IOS. All I do is delete the old one and everything is fine.

Hope this helps.

Sorry folks - been away.

Here’s where I am at and I also think I know what caused the issue but not why - if that makes sense? Here’s the cause:

My Scrivener folder was never Dropbox/Apps - I just didn’t like it so I went carefully through all necessary settings on Mac when I first purchased Scrivener 2, and iPad, and placed my projects in a different Dropbox folder. And for the last year or so it’s been fine. Then in a moment of madness! I decided to ‘re-boot’ (I have a NAS so copies are safe) and moved my ever-increasing projects to Dropbox/Apps/Scrivener/‘project title’. Again, all worked well until I tried to access my project(s) on a new iPad Pro, ‘Happy Christmas to me etc. etc.’ Since which time the Mac version has been fine but not the iPad - hence the submission here. In answer to a question: I have numerous projects, all of which were moved into Dropbox/Apps/Scrivener__ etc. etc. but just one project - the main one - fails to open on iPad.

I had tried the ‘obvious’ of re-naming in ‘save as’, letting Dropbox do its thing but the iPad still refused to open it. That said, and conscious that I may have missed-out a significant part (tiredness) I am re-doing this as I type. If the iPad opens it, I’ll move the original elsewhere (just in case!) and re-name the project as I like it. As the donkey said when the Ogre and Princess had left-him all alone: ‘I need a hug!’ Thanks guys, I’ll be back with update and hopefully happy news …


I ‘saved as’ my main project on my Mac but kept it in the same Dropbox/Apps/Scrivener folder. I closed Scrivener and watched Dropbox sync. This it did quite quickly. I opened Scrivener on my iPad Pro and it found the new project (I checked again but the original still will not open). Opening the newly named project on the iPad I am met with an altogether new problem:

The project opens fine however:
After clicking ‘Manuscript’ the numerous chapters in the project appear fine.
When I click on the ‘>’ to take me into a sub-section of the book, these also appear fine
When I try to go one deeper and open a chapter or pages within a chapter - blank. ‘0’ words appears at the bottom of every single page.

I have regularly asked it to re-sync with Dropbox - it does - but doesn’t show that it is downloading anything at all.

As I’m in UK and its now 0110 I’m off to beddy-byes - I’ll leave it all running and see if Dropbox somehow catches up (assuming its a syncing issue)…Unless something else is the problem?

Update 2:

No change. I’ve done all required - even painfully following Scrivener’s excellent iOS ‘sync’ guide. When I re-name the main project and allow Dropbox to sync then try and open it anywhere except the Mac (everything works fine on my Mac) the original project still refuses to open - same message as at the start of my diatribe - but now, even the re-named project, although it opens, every page is blank showing ‘zero words’. Scrivener techies pls, pls help me with this…

It’s somewhat difficult to follow your posts because vital information is provided like tidbits here and there.

Do I understand correctly that you have Scrivener on three devices?

Are all other projects syncing as expected between all three devices? And have you recently checked this by doing some minuscule changes in the other projects on your Mac and then synced to your iPad?

How do you check that the problem project is fully synced to the Dropbox server?

You mention you ‘moved’ the projects to a different folder. How did you do the move?

Hi folks, thanks for all the clarification questions. I can now say that all is well. I had moved the projects from Dropbox/Scrivener - my own folder that had worked fine for 18 months (pos 2), into the folder Lit&Lat recommend: Dropbox/Apps/Scrivener ( pos 1). My reason for doing so was that I had too many ‘non-Scrivener’ folders and files in ’pos 2’. It was strange that only my main project did not move ‘well’ and caused the headache. Anyway, I reversed my steps, leftDropbox overnight to do its stuff, re-moved my projects to ‘pos1’ and again left it 12 hours. This time everything is working and synced from ‘pos 1’ on Mac/Dropbox and opens perfectly on MacBook and iPad. So? I was either inpatient and did not allow Dropbox sufficient time to make the jump from ‘pos 2’ to ‘pos 1’, and/or, I failed to copy all files and folders in the original move. My bad, but all is well. Really appreciate the help and sorry to have waxed-lyrically for so long.

If a lot of projects are moved, it can take quite some time to upload all the changes to the Dropbox server, depending on the speed of the connection.

Glad you got it all sorted so you can get on with your work towards the next best seller… :wink:

Based on my own observations, there’s also some non-zero amount of “processing” time between when the Dropbox application reports a complete upload and when the data is available for download to another device. I’d definitely recommend a little extra caution when using it for “real time” switching between devices.


I’m also really not clear how to back and sync as i work on 2 devices. Is there a guide for this?


Guide for configuring iOS Scrivener to synchronize via Dropbox:
scrivener.tenderapp.com/help/kb … g-with-ios

Troubleshooting guide for iOS Scrivener synchronization:
scrivener.tenderapp.com/help/kb … os-syncing

Best practices for using Scrivener with cloud services: scrivener.tenderapp.com/help/kb … c-services

Note that only Dropbox is supported for synchronization with iOS Scrivener. For synchronizing between two Mac/Windows systems, most of the common services will work, subject to the caveats in the third link above.

Also, “backup” and “sync” are different operations. Confusion between them seems to be a significant source of problems.

A backup is a static archive of the project, whether created by Scrivener or some other tool. Synchronization is the act of updating a particular file or folder across multiple systems. Saving Scrivener’s automatic backups to Dropbox will not keep the live copy of the project synchronized, nor should Dropbox synchronization of the live copy be your only backup strategy.


many thanks working through this now