Is MMD dependable on a specific keyboard?

Hi there,

First let me explain why I’m posting this here and not at the recently created MMD google group – I’ve tried three times to post it there, but although the site says the post will appear soon, nothing happens. (However, it does send a copy to my email, since I asked for it. Very weird.) Therefore, until I find out what’s happening I’ll post it here.

I’m newbie at MMD and this is a very basic question:

Is MMD dependable on a specific keyboard (like the International one)? I’m using either a Spanish ISO or a Portuguese one and while testing MMD > HTML (on Scrivener) the weblinks don’t export correctly. Some do, some don’t. I’ve tried several ways and it keeps happening.

– MJ

I am not fully qualified to answer your question, but I do know of one that might be of service. Have you visited Scrivener’s Typography tab in Preferences? At the bottom, there is a selection which will choose an appropriate output script dependent upon the language you are using. Both Spanish (not sure whether or not it is ISO), and Portuguese are represented. This setting is global, however; not project specific. So if you publish something in a different language, you will have to remember to change that setting.

Thanks AmberV.

Apparently the problem only happens when I write with the Spanish ISO. Not with the Portuguese one. Most probably this is because Spanish ISO is not supported by Scrivener.

Well, now I know I can work around that. Even if writing natively in my MBP (Spanish ISO keyboard) is going to be a nightmare if I want to use MMD. :frowning:

– MJ

Sorry, I’m not sure what you mean. What exactly is the problem? I don’t think this has anything to do with Scrivener. MultiMarkdown is a separate thing entirely. Perhaps Fletcher can answer this. Scrivener uses UTF8 to export, so there really shouldn’t be any problem with other languages - are you using beta 4.1? Like I say, I don’t think there is a bug in Scrivener here. I will be interested in Fletcher’s interpretation…

I don’t think any of this has anything to do with the keyboard - what matters is the characters that are in the text file. MMD works fine with UTF-8, which is what Scrivener uses as well.

Post some sample text somewhere that doesn’t work and maybe we can figure out what’s going on.

Actually, after changing some things in the Preferences menu on Scrivener, everything seems to be well on exporting.

I’ll make more tests soon and, if the problem rises again, I’ll let you know.

– MJ