Is spelling and grammar check supposed to underline errors?

I’m used to typing faster Tham my fingers work so I spell things wrong quite a bit. Then I look for red underline words and fix when I’m at a stopping point.

Scrivener doesn’t seem to do that. I’ve tried checking and unchecking “Correct spelling errors as you type” and it does nothing.

Am I missing a setting somewhere?

I think I got it.

I had to turn on with Edit ▸ Spelling ▸ Check Spelling While Typing

It was on in Preferences, but I guess has to be toggled on too.