Is this a bug when trying to type i.e?

The video below shows what is happening.Basically I can type e.g with no problems but if I try to type i.e the first letter turns into a capital as soon as it is followed by the point. Any ideas? I’m using the latest version of Scrivener with OS X 10.7.4.

EDIT: I’ve just enlarged the video so it it is easier to see.

Hmm, very strange but when I do this in other places on the same page it isn’t always happening like this but I can’t see what could be causing this.


No, this isn’t a bug - it’s because “I” gets capitalised automatically. Just hit cmd-z (undo after it gets auto-capped to return it to lowercase. You’ll find the same thing happens in Pages.

All the best,

OK but just out of curiosity why doesn’t it happen on the next line then?

By the way, thank you, Keith, for letting us disable this kind of “helpful” auto-complete/auto-correct nonsense.

Sergent: In case it’s not clear, the I is capitalized because it has ‘word boundaries’ on either side of it. Spaces, quote marks, periods, commas… those kinds of things make it look, to the text engine, like you’re writing the personal pronoun. I disable the auto-correct setting that automatically capitalizes ‘i’ to avoid things like this. I also disable almost all other auto-correction, because …

In MY DAY, auto-correct was our BRAINS. If we forgot to capitalize the first letter of a sentence, we damned well knew we’d have to use white-out, or re-type the whole page, and we LIKED IT THAT WAY! Those where the GOOD 'OLE DAYS, I’m tellin you.

Damn kids and their ‘auto-co-rrect’.

That explains a lot.

I’m a sprightly 44 I’ll have you know but just a little confused whenever I have to use my brain :slight_smile:

Use of brain is optional (and highly discouraged for some) around here.

Sorry for my bad english! I’m Norwegian.

And that’s the problem. In Norwegian the letter i is translated to “in” not I as in “I am”.

It is very frustrating to have to hit “cmd+z” every time I write the letter i.

Any ideas?

Try this thread: Norwegian spelling and grammar

Turn off Preferences > Corrections > “Capitalize ‘i’”.

Bit embarrassing this, it’s in plain wiev in Preferences. Sorry for bothering you gyes and thanks a lot KB, I rely appreciate the help.


Not embarrassing at all, and no problem! For the next update, I have set things up so that, for new users, this will be turned off by default if the system spell-checker isn’t set to a variant of the English language.

All the best,