Issue: fonts and some cocoa apps

Some fonts do not work on scrivener or pages, whereas (or is it “whilst” ? English ain’t my native language, as u may notice from my accent :smiley: ) they do on textedit or word. :exclamation: :question:

Thanks in advance for your time

Could we perhaps have an example of these fonts or know what they are?

Mark

For instance symbol, which desperate need. I have tried with TrueType and OpenType version, deactivated both and reinstall only one at a time, but it did not work.
By the way I’m using 10.5.2

Right you are … I don’t know which version I have installed off-hand, the standard one that comes with Leopard I guess, and no, I can’t enter symbol from the keyboard.

While something is being done about it, you can enter symbol characters using the Character Palette. You have to choose the glyph, select it in the pane where all the fonts with that character are listed and the button turns to “Insert with font” and it will go in. Laborious, I know. I have to do it with Charis-SIL phonetic font which I use occasionally, as I don’t have a keyboard set-up for that font.

Keith, over to you … is it an Apple bug?

Mark

I don’t think this is anything Scrivener is doing… When trying to type using the Symbol font (on 10.5.2), I see exactly the same behaviour in Scrivener as in TextEdit - it just types in Lucida Grande instead.
Best,
Keith

another thing that may afflict you with woes is unvalidated fonts and font duplicates.

Way to check.

(1) Install the font you wish to use in the Fonts folder in the main library (not the user library). Make sure all applications are NOT running. (only finder)

HD/LIBRARY/FONTS

(2) After you copy the fonts there open FONT BOOK (Inside Applications Folder)
Look for any font that has a BULLET • to the right of its name. Highlight the font then go under EDIT and select RESOLVE DUPLICATES.

Do this with each Font that has a BULLET • to the right of its name.

(3) Verify the font is showing up in FONT BOOK.

(4) Highlight the font and go under FILE. Select VALIDATE FONT. Then make sure NO Bullet is beside the name (duplicate)

Then test to see if your font works in TEXT EDIT. If it works in TEXT EDIT it should work in SCR.

PS: another thing is to see if you installed TOO MANY FONTS. Sometimes when a person installs TOO MANY FONTS a program will only list a portion (The font list may stop at the N’s). This is rare though.

Thanks . Wock, I tried what you suggested with no luck. I have also tried a single-fresh copy on HD/system/library/fonts but it did not work either. I must submit a work on April 1st, so hopefully the solution will arrive on time. :confused:

can you email me the font?

I can test it see if we can’t fix this problem for you

pennywigeon@yahoo.com

Thanks, you are very kind.
I’m puzzled about something, though. Given that Keith experienced, the same problem with the same font, wouldn’t u conclude that is a system bug?
Once again, thanks for your time.
Best,
Felipe

It’s interesting, there are apps in which some fonts simply don’t appear in the list, where they do in others. In Swift Publisher, for instance, the Symbol font doesn’t seem to register in the standard Apple font window, though it does with Scrivener. Zapf Dingbats doesn’t appear in the font window when I’m running Tables … if I want a tick-mark I have to enter it through the Character Palette.

Must be a system bug of some kind, or one in the basic text handling.

Mark

The reason why I asked about your font was I was going to double check and see if it was the standard SYMBOL font supplied by Apple or if it was a “custom made” font. If it is then it is a Uni-Code font and the symbol characters are mapped to higher Uni-Code numbers and NOT mapped to actual Keystrokes.

This is done because most operating systems and SOME applications use the higher Uni-Code to display these symbols as Uni-code instead of exact font to prevent confusion when translating common character symbols.

The problems many people ran into long ago was symbols would be mapped to different keystrokes depending on the font and keyboard layout used and so say a web page wanted to display a certain character and the font helvetica wasn’t available but Arial was the symbol if mapped to a keystroke would appear different causing confusing and illegibility in font display. By mapping a certain Uni-code number the symbol could be put in the higher values and instead of being mapped to a keystroke of a certain keyboard layout it would have a unique Uni-code number that would be identical no matter what keyboard layout was chosen and thus fixing the problem.

The drawback is certain fonts are NOT mapped to a keystroke and cannot be obtained by typing a letter but must be retrieved using their Uni-code number or ASCII number for that particular font. SYMBOL is a prime example.

It is not a “Bug” but actually a feature. It is a “safety feature” to prevent a user from typing out characters specialized by that font that are used universally and then having font display problems when another computer is viewing the text.

TextEdit and many other applications cannot “type charaters” in the font Symbol because if you look at the actual font with a program such as Fontographer you would see that most of key mapping for keyboards is blank. So if you typed charaters in that font they would appear as nothing. Programs that access SYMBOL are actually kinda smart in that if you type in a character in SYMBOL it will default back to a System font (like times or helvetica). Making it appear that Symbol is a font that “doesn’t work” in most applications.

How to fix this?
Well you could use FONTOGRAPHER or another font editing utility and “create” a custom Symbol font (this is what some people do) and you would copy the characters from the higher Uni-code mapping) and then assign them to keystrokes and then create a custom font id number and custom font. (If you do this make sure to change the name of the font and the font ID so it does NOT conflict with SYMBOL or your whole operating system could act weird and cause problems).

Another alternate is to find a “Greek” font or Symbol font that is mapped to keystorkes online and use it.

Another work around was to find an old Keyboard layout from 10.2 or 10.1 called SYMBOL and switch to it when using SYMBOL font. This allowed you to “type” in the SYMBOL font.

Or the easiest way is to use the Keyboard Viewer and Character Pallete features of OSX and just “pop” the characters in when needed.

The last solution keeps the “characters” in a Uni-code format and if used to view on other computers is easier to translate than using a “cusomt font”

So in summary it is NOT Scrivener or TextEdit that has a “bug” but rather it is a “feature” of OSX and WIndows to prevent confusion when translating common symbols by using UNI-CODE for those common symbols instead of Keyboard Mapping.

PS: On a side note Programs like InDesign and Quark CAN use the SYMBOL font and access it fully. It is a limitation mainly found in Apple programs (Text Edit) and other programs that are based of Apple’s programs. You can go into InDesign and type out the full character set and apply SYMBOL font and it will display all of the characters. Copy and paste that into text edit and it appears in a default font (Times for me).

This is just another example why FONTs are usually cause for problems with computers. Adobe and Microsoft are trying to work it out with the OTF format but still issues with fonts still plague computer users. (I’d like to take the time to flip Apple the bird for the way they screwed everyone with the use of Helvetica and their stance on that issue!)

So it isn’t a bug but rather a font compatibility issue and until Apple changes their ways or offers better support when selecting these “special Fonts” we are stuck either suing their character pallette or creating our own custom fonts to circumvent their “safety” issues. Thank God Adobe at least allows use of these fonts…

Hope that helps?

Sorry for the rant…

I’m impressed by your lesson.Thanks for such detailed explanation. Definitively, I have a long way to go :blush:

Ok a fix that may help you with typing in “Symbol” font.

(1) Go to system preferences.
(2) Go to International (Top row 5th over)
(3) Select INPUT MENU tab
(4) Scroll down the list and check mark GREEK or GREEK POLYTONIC
(5) At the bottom of the window CHECK SHOW INPUT MENU BAR.
(6) Close Preferences.

(7) Open Scrivener. Create a blank Document and name it SYMBOLS
( 8 )In the top right hand corner of your screen you should see a flag denoting your default keyboard layout (mine is the american Flag) next to the clock and sound. Now click on that and Select GREEK
(9) Now under Fonts select SYMBOL.
(10) Type the alphebet in UPPERCASE then LOWER case then any other special characters. (YOu can use this method for copying and pasting characters)
(11) Then change your Input from Greek back to default.

(12) Now a few things you can do.
(a) is to switch inputs and fonts when needing to type in symbol. (Can be painstaking and slow if done alot.)
(b) Copy the character from your “alphabet”
© If it is only a certain symbol you need a lot like δ then what you can do is to “select” a special character in the standard font you are using (like • ) and use that symbol keystroke to denote a “place holder” for a certain symbol. Then use the FIND and replace feature to find • and then (go to your alphabet document and copy the character you want) and paste it in the replace field δ like so. Then find and replace all the • in your document with the δ symbol.

If that makes any sense?
Got your email and yes it is a Uni-Code font (all three) which means you would need to use the “greek” input method to be able to type them out. Once typed though they can be copied and pasted but once you start typing again unless you have the greek input selected you will default back to “Times” or “Helvetica”

If that makes any sense?

Example: I will change my INPUT to Greek then select SYMBOL as my Font in TEX EDIT.
I will then type what I want and copy it. I then change my INPUT Back to US Settings and Paste it here.

ΑΒΨΔΕΦΓΗΙΞΚΛΜΝΟΠ:ΡΣΤΘΩ΅ΧΥΖ
αβψδεφγηιξκλμνοπ;ρστθωςχυζ
:smiley:

The pigeon is speaking greek…

Hope that helps

Thanks Wock, that all makes sense.*

As for your keyboard switching suggestion, as someone who does so regularly, it is not that onerous, as long as you are only doing it between two keyboards (English and Simplified Chinese), as you can set up the standard key-stroke Cmd-Space to bring up the last used keyboard, so it goes back and forth painlessly. If you use multiple keyboards, you can set Cmd-Space up to cycle through them, but that becomes boring if you have to continually go through the cycle to get to the one you want. That is perhaps better than setting it up to bring up last used keyboard and using the menu to select one you use occasionally, as that one would immediately go onto the last-used list.

As I say, I use the Character Palette for the occasional symbols from Zapf Dingbats that I need and for access for a decent full phonetics font.

Mark

  • I couldn’t think of a way of saying “It’s Greek to me”, not even with reference to your alphabet, which is perhaps best classified as pidgin Greek :wink:

Those were “Pigeon Coordinates” for poop bombing runs.
(We encrypt our lists so it appears as “random”)
Like the keyboard trick for switching. Have to remember that one. :slight_smile: