Issue in export to FDX

Hi I was writing screenplay in Scrivener (in screenplay mode) and then decided to movie it to Final Draft 8. When I clicked Compile Draft and selected fdx as output format it created a file alright. However all the formatting of screenplay elements was lost and I had to manually format the screenplay in FD8. Do I have to select some setting to ensure that the formatting stays fine.

Compile Draft > Formatting panel, uncheck “Override text formatting”.

thanks. works perfect now.