Issue with downloading

I can’t download scrivener from your site. It states, “authentication failed”, when I try to run the dmg file. I have purchased the product but can’t download it. Any help on this?

I just saw another message with same issue and admin is responding that they are looking into. Seems to have happened to several people.

Try redownloading. I think it is a server problem that occasionally corrupts the file during download, though I am not sure. There is nothing wrong with the file itself, the problem seems to be caused during download. So, if you try re-downloading (it might take a couple of attempts), it should work. I will indeed look into this properly after the holidays, but right now I am celebrating with family so haven’t got time to look into it, sorry!
All the best,

I have tried many times on different days but still the same thing.

Have you tried downloading it with a different browser?

yes, safari and firefox.

Another user just reported to me that he tried downloading seven times and on the seventh, it worked. So, the file itself is okay, but it is a download problem. Unfortunately, this seems to be a server problem my end. I am working to resolve it with my providers, Aplus, but in the meantime, please try re-downloading. I’m really sorry for the pain involved, and hope to have this issue resolved ASAP. Goodness knows how many sales I’ve lost this month because of this… Ugh. Even worse, users who have already paid are having problems downloading - that is not good enough and I can only apologise profusely.
All the best,

Keith, what if you tried uploading it to a different server in the meantime, to see if that would work for now?

I’m looking into using Amazon S3 for now. Other than that, I haven’t got another server. And I can’t use a free one because they don’t allow commercial downloads…
Thanks though!
All the best,

Right, the file is now on Amazon’s S3 and it downloads fine from there. There are massive problems downloading from my web host right now and I’ve no idea why - and they haven’t exactly been very helpful in fixing it so far (i.e. they’ve just given me technical gobbledegook and things to try that have so far failed).

I’ll be moving over to a different web host soon, but I may keep the file on Amazon as it should be safe there. The direct link is:

Sorry for all the problems,
All the best,

Well I have some good news… I can not replicate this error.

Here is what I have done to verify:
2x Solaris 10 machines
4x Linux machines
1x MBP 10.4.11

In every case I could directly open the dmg and install scriv with no issues. I compared cksum of the files on the different machines and they are all identical. I used wget, lwp-retrieve, and firefox to DL the dmg on the non-OSX systems. I used Safari and a home-brew perl on OSX.

Is it possible that this is a Lepord thing?

Keith, I would still change the MIME for the DMG and ZIP to appliction/x-apple-diskimage and applicaiton/zip respectively.

Sorry I can’t be of more help than this.


Thanks for all your help Jaysen (Jaysen has put a lot of time in today helping me out with this out of plain kindness). I don’t think it’s a Leopard thing as I tried downloading to Tiger and had the same problem.

Thanks again!

I will mull it over. This is the kind of stuff I do for $$ and most of the time things just pop into focus (kind of like I hope the next chapter will).

If I think of anything I will let you know.