Issue with Keyboard Shortcut for Italic

Though I had always used CMD-I to toggle the format of text to italics, or from italics to normal, that no longer seems to work as I expect.

I don’t know if this was always the case, but Scrivener now lists CMD-I as the keyboard shortcut for two commands:
Format -> Text -> Center as well as Format -> Font -> Italics. When I had text selected, the Format command was always greyed out.

I have since gone into System Prefs, and changed the Center short cut to something else to remove the conflict. Now, normal text is changed to italic when I hit CMD-I. However, when I select text that is in italic, and hit CMD-I, it doesn’t toggle back to normal. Underlined and Bold text toggles as I expect using their keyboard shortcuts.

I have restarted, etc. Mac OS Sierra 10.12.6, Scrivener 2.8.1.

Just wondering if anyone has any suggestions why this is not behaving as I expect it to?

This must be a Sierra issue. In Mavericks if I select text, Cmd-I toggles italic on and off. To get Centre, I can go into the Text menu but find it much easier to use the Centre icon on the format toolbar.

Thanks for pointing this out. I had a problem one day(s) with this and had forgotten about it. Scratched my head for a bit.

Here’s what I just did to get the desired behavior for italic: I didn’t set a new shortcut for Center. In System Prefs, I set italic to cmd-I as if it didn’t previously exist in Scriv. Italic now toggles back and forth using cmd-I. Center no longer responds to cmd-I.

macOS 10.12.6, Scriv.2.8.1.2

I have the same OS and version of Scrivener and have seen nothing like the problem you describe (and presumably many others have that set-up too). So, something to do with your particular computer set up. I wonder what sort of changes have taken place recently. Upgrades/updates?

Something else is almost surely running interference. Do you run any utilities that capture keystrokes as part of their function?* Maybe a clean boot to see if disabling such utilities clears the problem would be revealing.

-gr

  • This might include any apps associated with items granted access under Sys Prefs > Security & Privacy > Privacy > Accessibility.

Thanks for the tip scshrugged. I followed that advice, but unfortunately no dice.

This has been ongoing since I updated to Sierra a couple of months ago, I’ve only just now gotten around to trying to sort it out.

I’ve tried the clean boot, with all apps previously granted accessibility privileges disabled (there were 4: Cheatsheet, Devonsphere Express, Spectacle and Dropbox).

Does anyone else have the same keyboard shortcut allocated to the Center and Italic commands by default? I had not changed either. Now, even when I have changed the Center shortcut, and kept Italic as CMD-I, that shortcut won’t even work. Screenshots attached.


Oh wait, I think I might have it!

How about this: your Italics command is going grey, because the selected text is in a font family for which you do not have an Italics typeface. So, I am betting you do not have the Italics typeface for your Goudy Old Style font family. You can easily check what typefaces you have for any font using the typeface pop-up on the formatting toolbar.

BTW, I think the default key command for Center is cmd-| (i.e., command-pipe) not cmd-I. The Mac’s system font makes the two look very similar.

gr

Thanks. Nothing like that for me in > Accessibility. Also have never had any third-party security software installed. The same is true for my keyboard/mouse; both use USB. No other utilities that would capture keystrokes.

I’m not sure what you meant by clean boot but I did start in Safe Mode today then rebooted normally and everything’s working correctly now. Perhaps I had a bit of corruption in the cache.

As far as the Center shortcut is concerned – It’s not actually an I (eye). It’s a | (pipe) as best as I can tell.

Our issues might’ve been different. Your Italic is greyed out, I see. Have you tried changing the font? Some fonts don’t support certain styles. Also, give Safe Mode a try. It is does clear out certain caches, including font and system ones.
support.apple.com/en-us/HT201262

[EDIT: I see gr beat me to the punch. :slight_smile: Sorry for the redundancy.)

Thanks both for the suggestion, but unfortunately that’s not it. The font I’m using has the italics typeface. Even if I switch to another (e.g. Times New Roman) the shortcut doesn’t work. And in any case, clicking on the italics button in the formatting toolbar converts Goudy Old Style to italics, so that’s definitely not the answer.

Am going to try restarting in Safe Mode. If that fails, will try resetting the NVRAM. Will report back.

Actually, I think it was the font. Checked in Text Edit and Mail, and when I use Goudy Old Style there the shortcut doesn’t work either. Have now changed font, and after some really weird behaviour and a couple of reboots in Safe Mode, the short cut is now working in, e.g. Palatino Linotype.

I still think it’s weird that I was able to change the font to italic using the button in the formatting bar, but not the shortcut.

Thanks for the advice!

Glad you got it sorted out – even if some things about the whole episode remain shrouded in mystery!

Best,
gr

Thanks for pointing this out - I was about to reply that “yes, I do have Cmd-I for both functions, though it only does italics for me”, but now I realise that the Centre shortcut has a pipe not an I (yes, they look the same in the Apple system font!).