Issue with keyboard shortcut

Has anyone had any problem with the “Expand All” (command-9) shortcut in View->Outline->Expand All?

It doesn’t work for me. “Collapse All” (command-0) does work.

So I’m thinking maybe I have this shortcut already assigned elsewhere. But I can’t find it in any other applications, at least in the shortcuts I’ve created in System Preferences->Keyboard->Shortcuts->App Shortcuts.

So I tried to assign it there from scratch. Didn’t work. I then created a new “Expand All” shortcut for Scrivener (control-option-command-9), and that doesn’t work.

When I do try to Expand All using the shortcut, ‘Format’ on the menu bar blinks (as though the shortcut is accessing something there?). I searched in the Format submenu for any conflicting shortcut and can’t find one.

Probably something with my machine but I don’t know where else to look.

Thanks for any ideas,

Michael

1 Like

Does it work when you trigger the menu command directly? I.e. is the feature itself seemingly broken, or just the ability to trigger it with a shortcut?

Also, it probably shouldn’t be triggering anything in the Format menu, but also check the other categories in that System Preference pane, particularly global and services shortcuts. Those will override application shortcuts. The other place to check is anything running in the Dock or the menu bar utility area. Obviously, for some of that, it may be easier to log out and then log back in with the Shift key held down to prevent any start-up programs from running. If it still doesn’t work, you know it isn’t another third-party program that is stealing it, at least.

It always worked triggering the command directly, yes.

I couldn’t find any identical shortcuts in any of the other System Preferences categories. So I followed your next advice, and rebooted in safe mode (or whatever it’s called while holding down shift key), and the problem was corrected. “Expand All” command-9 shortcut worked. I then restarted again as normal, to see if it stuck, and so far, it has. So maybe if it stops again I’ll look into what programs may have been running in the background that safe booting shut down.

Thank you very much!

Michael

I am experiencing this phenomenon now. Choosing View>Outline>Expand All or Collapse All works, but the equivalent keyboard shortcuts do not when applied in a contextually-relevant way. I need ideas!

Solved. I learned an important lesson today: many apps have a few internal shortcut preferences that can be set in that app’s preferences (and then perhaps forgotten by you). They can “cryptically” interfere with other shortcut-related software, in particular:

  1. MacOS Services preferences
  2. MacOS Keyboard shortcuts
  3. Keyboard Maestro macros
  4. TextExpander macros
    So don’t set them during app installation if you don’t intend to use them!
2 Likes

Yup! That “Services” section in System Preferences: Keyboard: Shortcuts is one of the first places I go if a printed shortcut in the software (as seen in the menu) doesn’t work. I feel it should be considered good etiquette to leave your application’s Services unbound on installation, but that doesn’t always seem to happen.

Genuine globals (like Scrivener’s Scratch Pad shortcut, found in its General: Scratch Pad section) are more tricky to track down as there is no central list. Maybe some utility can help with that though.