Issue with permissions and saving with v12

After installing the latest release, the first time Scrivener attempted autosave it froze, and eventually gave me an error message: (I can’t work out how to post a screenshot here - extracts of it below)
Could not save project document ‘Arrival’
Failed saving text for …
Error: ‘Could not open file for writing’
Error: ‘Access is denied’
Then some tips that appeared to think I was out of storage space.

After restarting and trying again, this time I also got a message from my Avast virus protection, saying it had blocked access from Scrivener to a protected Dropbox file. It gave me the option of allowing access, and it seemed to work fine after that.

So I’ve solved the problem, BUT this has nev er happened on previous upgrades.

Avast and other third-party anti-virus scanners have the potential to create this problem, as they can get over-zealous and attempt to inspect every attempt at disk access – and it can seem very random when they decide a given interaction is problematic or not.

One of the easiest ways to avoid this issue is to make use of your antivirus software’s “whitelist” capability (most of them that do realtime file and process scanning like this also have this feature) where you can add the Scrivener executable to a list of programs that Avast knows not to try to scan file access to. This can help you avoid this and other potential problems.

Same with me, but Avast at least put up its normal warning that it does in situation to let me know that it had blocked Scrivener. All good now.

Have in mind that many antivirus apps, flag new installers which have never been seen and reported as safe from the antivirus app community. Best thing to do is white list the newly downloaded installer and the installed Scrivener folder.


I have the same issue.
I don’t have issue with Avast or other antivirus, only the message to save my project.

I tried to create a new project as it is proposed, but it does not work. Even after a reboot of the pc.


I have exactly the same problem. Has anyone been able to fix it?


I fixed it by allowing the app (Scrivener 3) in Avast. I had my Avast set to silent mode to not deal with the pop up for the daily scan. Silent mode caused Avast to not notify me when it blocked Scrivener. I turned off Avast when reinstalling RC12 and testing whether it would save a document. (Here is another thread dealing with the same issue: It worked properly, so once I enabled Avast again, I went to the main Status page in Avast. I selected Menu, Settings, Blocked & Allowed Apps, and added Scrivener.exe to the allowed list:
[attachment=0]Avast Allow App.jpg[/attachment]

Thanks for the help, Devin. For those with the problem but not using Avast, I’d guess you need to add Scrivener.exe to the white list as mentioned above.

Compile still failed, so I had to add aspose.exe to the allowed list for that to work. There are other .exe files in the Scrivener folder and subfolders, so I’ll leave silent mode off to see any other blocking notices.

I don’t understand why RC12 triggers these ransomware blocks when none of the other betas or RCs did, but as long as I can get it working, that’s for someone else to figure out.