Issues pasting from Scrivener to Notes

I just tried pasting text from a Scrivener document to the Apple Notes app, and it refused to let me paste the text and instead inserted this:

This is a bit frustrating. Has anyone else experienced this?

Pasting from any other app into Notes seems to work fine, whether rich text or plain text.

Just tested this and the same thing happens to me.

As far as I can tell, it only happens with OneNote. I’ve successfully copy and pasted text to Messages from other apps. And I’ve successfully copy and pasted text from OneNote to other apps. I’ve also deleted and reinstalled OneNote.

I have no luck reproducing that in IOS 13.4.1. Pasting into Notes works the way it always has worked, with simple formatting and images intact.

I doubt OneNote has much to do with how Apple Notes work, being made by Microsoft. That said, for both cases, it is generally up to the software receiving pasted text to support the system standard clipboard format, or if it cannot do that, to select from the provided plain-text variant instead.

I tested.
Opened iOS Scrivener
Copied a paragraph of text.
Opened Apple Notes.
Pasted.

No problem.