Issues under Wine: pdf-viewing, temtplates and spelling

Hey there,

I have tried the Linux version once, with not much success (see here), but I bought Scrivener for Windows some months ago and recently had the idea of just trying my Windows version under Wine now.

edit: oh, and it is still the same netbook, but with latest Ubuntu 12.04 updates and the latest Scrivener Windows version, I also made a fresh Wine installation beforehand

It works pretty good, it is actually usable with Wine but I still recognized two/three isses:

[]When I opened a short story template, I couldn’t view the included sample pdf of the compile, it only showed me a blank white pdf. Adding my own Pdf’s though worked! Also the pdf is still viewable under windows.[/]

[]When creating a character or sheet list via “create new/template/character sketch”, it creates a new text item but it doesn’t copy the template texts and just creates an empty text object. Works under windows but the created templates under Linux are obviously still empty.[/]

[]Spelling for other languages (german in my case) also doesn’t seem to work with the wine variant, it fails to download them. But I think this is a well known issue.[/]

Anyways, I might report more issues if I stumble upon them. Suggestions for fixes or any hope for addition into the soon to be fixed list highly appreciated for sure :stuck_out_tongue:

Thank you, bye!

Are you using the most recent version of WINE (1.7.23, I believe) and the most recent version of Scrivener? There’s some fairly substantial PDF handling changes (read: it works now).

While I’ve no beef with WINE (as my Steam library will attest), you may want to give the Linux version a try again, too. It’s gotten 110% better and faster. (With 64 bit support.)

I use 1.7.18 Wine and 1.7.2 Scrivener

it is not a big issue, as I usually don’t make use of templates anyways and the german dictionary is pretty bad as well, but I just wanted to report them somewhere

I will have to try the Linux version again, but I think a lot of the issues I had last year were mostly because I run it on a netbook and note a desktop, which might not be within the scope of the port currently.

Thank you for the help