Issues with an old document

I have a story I’ve been writing off and on for about 15 years. For much of that time, I’ve used Scrivener, and with every Scrivener update, I’d update the story.

Now, it’s getting close to being finished, and I’m running into issues trying to compile.

When I compile it, formatting changes that don’t show in the document occur between paragraphs. In my document, each folder marks a chapter and is set as Chapter Heading. In the folder are 2 pages, the first a quote (italicized) to start the chapter, and the second is the story chapter.

It doesn’t seem to matter what the formatting says (each quote is a section, and each chapter is a chapter, but I’ve tried nearly every layout option… this is just the last one). Regardless of how I change it, it is still messed up when I try to compile.

I guess I should also say that it doesn’t matter how I change the formatting on my document either…I’ve tried to set formatting for the entire document, but nothing changes unless I select each page and change the formatting for that page. I’m guessing this is an issue caused by writing this story for a very long time through multiple versions of Scrivener.

Is there a way to fix this? I’m at a loss. Even trying to copy formatting to the entire document changes nothing.

To clarify, is each of these a document under the Chapter folder, or is this text inside the Chapter folder?

In what way in the Compiled document messed up? Text not appearing, not formatted as expected, etc?

If the text is all there and you’re willing to format by hand, the easiest thing would be to compile to .docx and open with a word processor and format by hand there. If all of your text isn’t compiling, then it’s a matter of getting the proper setup first, which will likely also resolve your formatting issues.

1 Like

To clarify, is each of these a document under the Chapter folder, or is this text inside the Chapter folder?


In what way in the Compiled document messed up? Text not appearing, not formatted as expected, etc?

This is from the same page. There’s no reason I can figure for it to have a different format, but…

This is what it looks like in Scrivener uncompiled:


I’m willing to format by hand if I have to, but it’s 80K words, so I’d really prefer not to. But yeah, if that’s the only solution, then I’ll do it.

In Scrivener 3, structure doesn’t matter. Section types do. If two documents are formatted differently, some combination of these are true:

  • they have two different section types
  • they have the same section type, but they’re compiled as-is (and Editor formatting is different)
  • they have the same section type, but they have styles applied to some of the text

It doesn’t matter if you think two things are both chapters (which isn’t a Scrivener concept) or whether they’re both at the same level in the Binder and both are folders.

What matters is their section types.

When I say they’re from the same page, I mean literally the same document. Basically, the blue highlighted item in the image below, when compiled, results in two different types of formatting.


If you meant the screenshot to show two formats on the same page, it does not. If it’s two paragraphs formatted differently in one document, we’re back to one of the scenarios I listed, where formatting is as-is (and they’re different in the Editor) or they’re formatted with two different styles (or one is No Style.)

This is the screenshot that shows 2 formats on the same page. This is what the page looks like before compiling:


I don’t know why the hashtags are added, in some parts of the compiled documents, they’re added after every paragraph.


These aren’t and never have been separated in my writing, and it doesn’t happen all the time, but for some chapters, there is a separation between every paragraph and in others, it compiles like it should. Nothing is different in the settings between the two, and sometimes paragraphs will hashtag or change font on the same page that other paragraphs are fine. Even with pages that I wrote today, this happens.

It may be true, but those screenshots don’t prove that you have different formatting (in a Compiled product) for text in the same document. You haven’t shown that it’s not due to different formatting in the Editor, either.

The hashtags look much like the default Separators in some project between documents. If you don’t know where they came from, that’s a possible explanation. Here’s another, perhaps more likely. It applies wherever you have blank lines. If you don’t want the hashtags, edit the setting.

To be clear, these screenshots seem to show different-sized text for the paragraphs with different-sized text in the Compiled result. No surprise. It could be that they’re actually the same size in the Editor, but the screenshots don’t show them together.

I don’t know how to prove that they’re from the same document.

Also, it might be easier to converse if we define our terms. I think you’re using document to mean the same thing I mean when I say page…a single text item in a file folder.

From my understanding, that single text item can be set to compile as a section, chapter, or several other options, but I think that’s the two that matter here.

So my problem is that eventually all my folders will contain 2 single text items…a quote that should go above the chapter and then the written chapter itself.

And it’s likely that because I want the quote to be italicized, that’s what’s causing most of the issues.

I did figure out the different formatting in the same text item I showed, well, tried to show…I deleted the paragraph up to the previous paragraph, then hit enter again and now it is the way it should be, but I’m still having the other issues with mixed formatting on different text items that should have the same formatting, and the hashtags inside text items.

Also, this is the is the screenshot that was two paragraphs from the same text item (and they looked normal in the pre-compiled manuscript) that were formatting differently. You’ve mentioned a couple times that you didn’t see it, but I’m not sure if you meant you didn’t see the issue I was referring to or the image itself.

Thank you, @JenT and @drmajorbob for your help! I created a new Scrivener manuscript and pulled each chapter over individually to the new manuscript. From there, I was able to reformat the chapters one at a time, which finally made hidden issues with the coding between paragraphs appear. Now when I compile it, everything is looking like it should.

I really apprecite your time and help. Thank you again!

1 Like

Pages and documents are not the same thing. A document may or may not have a page break when compiled, and you should never include page breaks in the Editor.

Section and chapter are not specific Scrivener concepts; they’re just English words.

Any word or phrase can be a section type, such as “scene with separator”, “scene without separator”, “chapter”, “setting”, etc. One you’ve created a section type (or it was already built in to the project template), you can apply that section type to any document.

I use “chapter” as the section type for a chapter folder, “epigraph” for the quotes, “setting” for a document that include place/time, and “scene” for scenes within the chapter. (Actually three kinds of scenes, two of them mentioned above.)

Exactly right. My “epigraph” section layout is centered, but my “scene” section layouts are not. The “setting” section layout is bold, but the others are not.

To make them the same, use the same section type. To make them different, use a different section type. If that’s not working, there will be a logical reason for it relating to the “as-is” setting and/or the use of styles, if you used any.

1 Like

Glad you were able to figure it out! When there’s odd compiling issues within a document, one good way to go is to highlight text and re-apply the No Style paragraph style—that often gets rid of any odd issues from copying/pasting text, applying paragraph styles, etc. If you don’t have any paragraph styles like block quotes in your manuscript, you can go in Scrivenings mode, command+A to select all text, and then re-apply the No Style “style” that way. Pulling your documents over to a new project file can be another good way to go!

1 Like