Issues with V3 compiler

So, I’ve found the learning curve a bit longer with the new V3 compiler, but I like the flexibility I see. That said, I have two issues with attempting to compile eBook versions of my latest novel. First, nothing compiles to Bold. I’ve tried several different section layouts trying to customize my chapter headings in bold and 18pts. The layout shows things as I want but they always compile to normal text. Also, the chapter header (eg. Chapter One) is given its own page with the text following on the subsequent page. What I’m trying to do is have the header dropped down 6 lines from the top margin with the scene text following a couple of lines below that. Again, I’ve tried several layouts and customizing each for this without success. The manual is of no help with this. Suggestions?? Thanks.

Bold formatting seems to be working fine for me. Here is what I tried:

  1. I duplicated and edited the stock “Ebook” format.
  2. Went into the Styles pane and went through all of the styles here related to headings, setting them to bold.

Upon compiling with these settings, I see bold in the editor I’m using to examine the ePub (Sigil), and can verify that the styles I changed are using the correct CSS. For example, here is the CSS for the Title style:

.title {
    margin: 0rem 0rem 1.11rem 0rem;
    text-indent: 0rem;
    text-align: center;
    font-size: 1.33rem;
    font-weight: bold;
}

Also, the chapter header (eg. Chapter One) is given its own page with the text following on the subsequent page.

It’s hard to say what is going on without some information on how you organise your writings in the binder, and which Layouts you use for that arrangement. It could be you are using a layout like “New Section”, when the “Section Text” layout would work better. Whatever the case you should be seeing an indicator that this will happen in the compile preview column in the middle. Any layout that inserts a section break will have a marker at the top.

Thanks, Amber. Essentially, I did just what you stated for steps 1 & 2 above, although I only set to bold those layouts I thought I’d use. Just to make sure, I deleted that format and repeated your steps. Still, nothing in bold. I should have mentioned that I’m formatting for mobi first, not epub per se. Don’t know if that makes a difference. Also, for my front matter (title page, copyright, and dedication), I’m using an “as-is” layout and in the editor, I have my title in bold, as well as the headings “COPYRIGHT” and “DEDICATION.” Despite being bold in the editor and using an “as-is” layout, everything goes to regular text upon compiling.

In my binder, I have folders for every chapter and they’re titled “One,” “Two,” etc. in the binder. Within each folder, I have separate documents for each scene. The scenes I have set as “sections” using an ‘as-is’ layout for that. They seem to compile just fine except for two scenes where I have a date label (eg, February 2020) in bold at the start of the scene. They, too, compile into regular text despite the “as-is” layout. For the chapters, I’ve set them to “Section Start” and have tried various layouts–Heading, Chapter, Chapter - bordered, Section with title, new section. I’ve lost track of what I tried at this point. When I check the formatting for each layout, it shows the heading as bold but never compiles that way. I had no trouble compiling with bold, etc. in V1. This has been very frustrating.

Okay, so I played around with my title page and discovered that if I set styles (title, heading 1) in the editor, I now get bold when I compile those “as-is” pages. And my chapter headings are now compiling to bold after changing those defaults. But I had to change the defaults. Trying to edit them in the compiler on-the-fly doesn’t work. I’m still getting the chapter heading on its own page.

And my chapter headings are now compiling to bold after changing those defaults. But I had to change the defaults. Trying to edit them in the compiler on-the-fly doesn’t work. I’m still getting the chapter heading on its own page.

Well that would make sense to edit the defaults, since none of the stock ebook formatting uses bold, I don’t think. If you want bold headings you would need to edit the Ebook compile format and change the format’s style settings (which in turn will change the layouts that use those styles, and any text that use those styles in the editor).

But then again you say editing them on the fly doesn’t work, so I’m not really following where you went with this, I’m afraid.

At any rate I’m attaching an example of what I tried. As you can see, all of the headings are bold, and the bold text I added in the editor is bold as well.

It sounds like my setup may be considerably simpler than yours though, you may have more variables going on—more complexity—and maybe that is getting in the way. Maybe if you can pare things down a bit to the basics it will work better, and this will help demonstrate that. I’ve set up the folders/text the way you described for the typical chapter+scene layout.

You’ll note I’m not using “as-is” or anything, just stock settings. A chapter heading style for the folder, and “Section Text” for the scenes.

bold_output_test.zip (165.0 KB)

I downloaded your example but for some reason can’t access it.

By “on-the-fly” I meant that after assigning layouts to the different formats, if I double-click on the layout in the middle panel of the compile window and change the formatting there, it doesn’t seem to make the change. I’ve tried changing between default, custom, and editor formats for text and notes, and no matter what I select, the formatting goes with whatever I’ve defined as the default for that layout. Thus, when I edited the default settings for format, I was finally able to get bold text out of the compiler.

So, at this point, I’m finally getting the bold text where I want it. My remaining problem is that the chapter heading continues to get its own page, with the text starting on the next page. While I want chapters to start on new pages, I simply want the text to follow the heading on the same page.

Had to recopy your sample and put it in a separate folder, but I finally got to see your example. I changed my scene format to the ‘section text’ layout and that has succeeded in getting my chapters and scenes to compile correctly. Thank you.

I still have some minor things to figure out and resolve. Ex: My chapters one and two headings are coming out bold, as desired, but chapter three and on revert back to regular text. What I’m discovering is that there’s a lot more to using ‘styles’ in V3 than I expected. It’s a new facet of the program I need to learn. Likewise with my title page. In the editor, the title is larger than my name, with both in bold, but once compiled my name is larger than the title. The title’s style is ‘title’ while I use ‘heading 1’ for my name. Apparently, I need to figure out how to format those defaults to my liking.

I’m getting there. Thanks again for your help.

Great, glad to hear you’ve got the bold problem resolved. That’s a strange one, as it is one of the few things that is difficult to suppress or override, because formatting like bold and italics are meant to be ignored by most of the formatting override settings.

Styles are definitely an important ingredient in Ebook formatting. They aren’t necessary, I would say, but taking the time to learn how they work will make things easier for you in the long run.

The title’s style is ‘title’ while I use ‘heading 1’ for my name. Apparently, I need to figure out how to format those defaults to my liking.

My philosophy with styles, and this is aligned with what is considered good practices on the whole, is that text should be assigned to styles that are meaningfully connected with the purpose for that text. In this particular case, I would create a style called “Book Title” and another styled called “Author”, and then establish their formatting directly. Even if I never use these styles again, it’s better than using styles made for other purposes, simply to affect whatever font settings they use.

And since those are used for chapter styling and such, changing how they look in the Styles pane to suit the title page would make a mess of things elsewhere.

The approach you’ve described wouldn’t make sense (in a document design sense), because “Heading 1” (and heading 2, 3, 4…) are used to describe a document outline, like how you would use the binder outline to describe a topical flow. Heading 1 is the top of that outline—usually the chapter heading text, then sections within that chapter would be Heading 2, subsections Heading 3, and so on. So those are all special styles, intended for that purpose.

The “Title” one is more intuitive, but it’s worth noting this style is used by the default Section Layouts as major headings, like chapter text. So you’re in effect using a chapter heading style for your book title.

Like I say, this isn’t really a Scrivener thing, per se. We’re in fact using these conventions because they work well in established techniques in word processors and HTML document structure.

Thanks again, Amber. I came to realize that the existing styles couldn’t be edited, and that if they were, they’d mess up other areas. So, I’m going to take your advice and create the new ones. I have 12 novels out already, so they’ll be put to good use. :slightly_smiling_face:

Having finally gotten the compiler to do what I wanted for my last novel, I’m now working on a non-fiction book and finding it just as difficult, or more so, to use the compiler for it. As with the novel, the compiler won’t properly compile bold text. I had to create a separate style just for bold, which makes it a minor pain. The compiler handles italics just fine, so I don’t know why bold should be different.

The real challenge came in organizing my text, which basically has three levels–chapter, major sections labeled with what I’m calling a sub-title, and minor sections labeled by what I’m calling sub-headings. The chapters have text labels, not numerical ones, but apparently using any of the “chapter” layouts adds a numerical label, whether text (ONE) or numerical (1). I learned I needed to use “titles” to get the proper labels on my chapters. So far, okay. But my sub-titles should be 16 pt, centered, and bold, and the sub-headings are 14pt, left justified, and bold. I need both to have options for a page break before them, as well as not having a page break before them. I also need to keep the “section text” layout for sections that have no label. There are only three layouts that don’t force a page break in front, and I’ve now edited two of them to fit my needs, while leaving “section text” alone. However, what if I find a need to add another level of text requiring a sub-title or sub-heading and no page break? Is there a way to create a new layout or to edit and remove the page break from an existing layout I don’t need? I haven’t found either as a feature of V3.

Two other problems I discovered are (1)in defining font size and (2)that defining a title by font size and bold in the editor leads to a different appearance from defining the same in the compiler. First one . . . the options for font size make big jumps. My other non-fiction title in this series uses 16 pt for sub-titles. I’m not given that choice and have to go with 18pt. But then after 18 pt comes 24pt followed by 36 pt. There needs to be more options, such as 16, 20, 22, 30, & 32. To remain consistent within the series, my chapters, sub-titles, and sub-headings should be 20pt, 16pt, and 14pt respectively, but I’m not being offered the first two as choices.

Second one . . . I initially had a large section in which I had the sub-headings written into the editor and defined as a separately created style for 14pt, left, and bold. The title of the section was defined in the compiler as 18pt, ctr, and bold. In reviewing a test ebook from the compiler, the sub-heading was much bolder and larger than the title. That shouldn’t be. Plus, I found that even though I created several styles, those were not available to me as styles in the compiler. I ultimately had to reorganize and redefine that large section in order to get a consistent appearance. If I define something as, say, 18pt, centered, and bold in the editor and also in the compiler they should look the same in the ebook. They don’t.

I will figure this out and continue to use Scrivener for compiling my ebooks, but it looks like I’ll have to export the manuscript to Word for final formatting of the paperback. That will be so much easier. Trying to figure out this compiler has taken so much of my time, I’m beginning to think I should have just stuck with V1.

These may be helpful.

Compile Overview

Headings

Synopsis/Epigraph (compiling a completely different export from the same contents)

1 Like

Another must-have resource is the migration guide. It is written specifically for veteran v1 users who are comfortable with the old compile system, to get you up to speed on the new system. Many of the questions you are asking are covered there.

Thanks, drmajorbob. The Headings review had one image that showed me where to create new layouts. That was one of my major issues and I just never saw the + sign in the top right corner. I had tried editing existing layouts but could never figure out how to eliminate a page break. In looking through the other topics you suggested, I realize that I’m understanding this new compiler better than I thought. BTW, I was once a drmajor, too. Still the dr, but not the major. lol

Thanks, Amber. I perused this guide when I first started V3, but I’ll need to review it again now that I’ve had experience using V3 and know what questions I have.

At the stage you’re at, I think the section titled “Updating Old Compile Settings” may be most beneficial, though it sounds like from the above you’re getting past the hump that might have helped you with.

It explains where I was having trouble understanding the blocks you were facing, in not knowing you could even create your own Layouts or make extensive modifications to the stock examples. You can pretty much change everything you see—and that goes for styles as well. Delete them all, start from scratch, whatever you want. In fact I have a Format called “Blank” that I tend to start from that has nothing in it but two simple layouts (one with a plain-text heading and the other with as-is text), no styles nothing. I like to build up, rather than dismantle completed systems and worry about breaking interdependencies within them.

It’s a matter of taste for sure, and when you’re just starting out, having a bunch of infrastructure and examples can be very helpful, but it’s maybe something to give some thought to, if you found in v1 you tended to work from a basic setup at the start.

On the matter of bold still not working, I have no idea! I think you may need to send us in a sample snippet project, just enough text and compile settings to demonstrate it (feel free to PM if you need). I have never seen bold get lost in an ebook like you describe. Maybe in rich text oriented stuff, if you choose a font that doesn’t even have bold, that comes up every once in a while, but there aren’t many fonts that lack bold.

1 Like

Make a habit of noticing every icon. Hover over them to get hints.

Yeah, I’m still a PhD (operations research), but only a retired USAF major.

Okay. So I created a new layout and it, too, has a page break preceding it. How do I get a layout without that page break?

Go to the Separators pane and change the separator for that layout. Or duplicate the layout and make the change there.

Ah! So that’s where it is. Found it. Thanks.

It might have been better to leave page breaks in the Inspector, as they were in Scrivener 1 and 2, but it would violate the principle of compiling documents according to their section type.