Italic causes incorrect font

When I apply italic text to a manuscript document, it uses .AppleSystemUIFontMonospaced instead of the original font (in this case, Ubuntu Mono). It does italicize the text, however. This occurs whether I use the keyboard shortcut or the formatting bar.

Scrivener: 3.1.5 (12258)
macOS: 11.0.1 (20B29)

Having a similar issue running Scrivener 3.2 on macOS Big Sur 11.0.1. I’m using Courier Prime Sans (Regular) as my composition font. When I highlight text and press Command + I, it changes it to an italic version of .AppleSystemUIFontMonospaced. However, if I select the Italic variation of the font from the formatting toolbar, Scrivener properly applies Courier Prime Sans Italic. Previous uses of Courier Prime Sans Italic remain unaffected.

When I was running Scrivener 3.1.5 on macOS Catalina 10.15.7 and using the same composition font, Command + I worked as expected. So if I had to guess, it’s something to do with Big Sur specifically.

I’ve just tried it on a fresh install of Big Sur (so 11.0.1) and Scrivener 3.2 (build 14233), and cmd-i works for italics in Courier Prime Sans as normal;

[attachment=0]Screenshot 2020-11-18 at 08.21.41.png[/attachment]

I can try it later on the laptop, which is upgraded rather than installed from fresh. I had to install Courier Prime Sans to carry out the test, so it may be an artefact of the install v upgrade process for fonts, perhaps?

Ahh, good call! I’ve been getting this bug too, on an upgrade from Catalina. After reading your post, I looked in Font Book and saw that Courier Prime wasn’t listed anywhere. I reinstalled it and Scrivener works as expected now.

There is a very bizarre Big Sur bug here - I tracked it down to caching fonts during app startup for font menus, which is very odd. I’ve reported the bug to Apple and have it fixed in the updated version of 3.2 that will go live shortly. Then I’ll push out a 3.2.1 update to catch early adopters of 3.2 in the next week or two (I can’t release that yet because I have yet to upload 3.2 to the App Store following all the issues, and it’s not possible to create a new version on the App Store without releasing the previous one).

Just updated to the latest build of 3.2 (14343), and Command + I appears to be working properly for me again. :smiley:

Now to write the rest of my NaNoWriMo Novel!

Yes, for anyone experiencing this issue, please delete your copy of Scrivener 3.2 and re-download from the site (Check for Updates won’t do anything because the version is still 3.2). Build 14343 fixes it. Normally I would do an incremental update for this (so available via Check for Updates), but I can’t do that until 3.2 is available on the App Store too (I’ve just submitted it now that the worst issues seem to have been dealt with).

All the best,

Amazing work! Now, I have no excuse for not finishing the edit of my novel.

Oh, wait . . . can I have the bug back, please?


I’m on build 14343; I actually deleted 3.2 and re-downloaded it and reinstalled it, and Compile STILL does not work for me.

It’s quite likely that this thread will be a better place to report what is happening than one about italics causing a font shift in the editor. Do note that some level of detail will be required to sort out what is going on. I’ve compiled about eight different things to a variety of different formats today, using the latest build. So whatever you’re seeing is likely going to take some detective work.

Yes, I apologize, I actually INTENDED to post it in the other thread, made a simple mistake. :slight_smile:

No worries, just helping to get things organised. :slight_smile:

So I tried that and compile is still not working. I am on Mac Big Sur 11.0.1. Any other thoughts? I also tried to download the previous version and got a “this file is corrupted and cannot be downloaded”. So I can’t seem to roll back.

This did not work for me. I newly downloaded Scrivener shows a new icon (so I know it’s the new one) but clicking on Compile causes nothing to happen, just as before.

I am on a Macbook Air running Catalina.

NB All I deleted was the app, not the support files (obviously I did not want to lose preferences and settings). Is this relevant to the problem?



Unfortunately there’s a known bug in the latest version of 3.2 that can cause Compile to throw an error (and not appear) if it was set to override the Compile format font. I’ll have a 3.2.1 fix out for this tomorrow.

All the best,

Thanks, Keith. Thanks as ever for being responsive, conscientious and smart! I know this must be an , um, interesting week, with a new version and new system. But we Scrivenarians know we’re in good hands.

all the best to you,